Skip to Content
author's profile photo Former Member
Former Member

MultiProvider Assignment Identification Issues

Hi All, I have been trying to create a Multiprovider over two of Infocubes which are 'joining' on the characteristic Document Number, and have hit a bit of a problem since the two cubes share the same time dimensions, 0FISCPER + 0FISCVARNT, but with dates therein being different. When I am building the MP it automatically assigns/joins on the 0FISCPER dimension, and does not allow me to report (or filter) on the share data as it sees the fiscal periods as different and produce two separate records . This means that I am unable to view the data from both cubes in the same record, producing results similar to the following: Current Results Doc. No CHAR1 CHAR2 KF1 KF2 1234567890 ABC # 1234 # # DEF # 567

Desired Results

Doc No CHAR1 CHAR2 KF1 KF2 1234567890 ABC DEF 1234 567

Can anyone advise if there is a way around this issue (with or without using a Multiprovider)?

Thanks in advance,

Derrick

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Posted on Aug 16, 2013 at 07:50 PM

    HI

    You need to populate the other characteristic in the cube load if you want to see them the way you show it in you screen. Do you have a DSO before the cube that would allow you to read the other characteristic. Shouldn't be a big deal since they share doc no.

    hope it helps

    Martin

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 16, 2013 at 09:40 PM

    Hi Derrick,

    Try this out,

    1) Do a look up and Populate the same Date as the other Cube.

    Or

    2) In the cube Properties if you compress the Data in the cube the you should be able to see the data as required by you.

    rgds

    SVU

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 19, 2013 at 12:52 PM

    Hi Derrick,

    You need to have other characteristics in the info cube. You can get the other characteristics doing a lookup based upon document number.

    thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 30, 2013 at 11:29 AM

    Hi Guys,

    Thanks for all of your input/advise

    I have discovered the reason for my data not joining correctly from the two infocubes, was due to the fact I am using a Multiprovider and it combines the data from the source(s).

    The following article has an in depth discussion of the differences between how Multiproviders and Infosets combine data from other InfoObjects, but basically . . .

    "Multiproviders do unions, whereas Infosets do joins"

    We have now created an Infoset over the two Infocubes, and the data is now joining together as expected.

    Regards,

    Derrick

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 30, 2013 at 02:58 PM

    Use Constant Selection on Char1 and Char2 for your both KFs in the Bex Query. Hope you may get single record..

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.