Skip to Content
0
Aug 15, 2013 at 04:38 PM

PI JDBC MSSQL - JRE version 1.6 is not supported by this driver

305 Views

Greetings

Im getting this error when trying to connect PI 7.3 to a MS SQL Database:

"Exception Occurred : Java Runtime Environment (JRE) version 1.6 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0."

I am actually using the PI_URL/ftpjdbc "Qucik Connectity Test" diagnostic tool to test this.

So I have added sqljdbc4.jar to com.sap.aii.adapter.lib.sda and this has been successfully deployed using JSPM

However, I'm still getting the same error. The URL I am using is com.microsoft.sqlserver.jdbc.SQLServerDriver

Im not sure if this is related to the fact that I have both sqljdbc.jar and sqljdbc4.jar included.

Any ideas please?

Regards

Steve

Attachments

driver.JPG (16.1 kB)
driverXML.JPG (67.9 kB)