Skip to Content
avatar image
Former Member

Server configuration file for SAP GUI 7.30 doesn't work on Citrix XenApp

Hi all

We upgraded from SAP GUI 7.20 to SAP GUI 7.30 and within this upgrade we also upgraded our ctrix server farm. Unfortunately when a user opens SAP Logon within XenApp, the following error occurs:

"I'll try to translate: SAP Logon could not be started correctly.

Error while loading local configuration files:
Name of tree structure file http://<server>/SapLogonTree.xml invalid."

The server configuration file works well on normal clients. Also the file works well if I log in via administration console on the citrix server. I deleted registry entry HKLM\SOFTWARE\Wow6432Node\SAP\SAPLogon\Options\ConfigFileOnServer (was set with installation/upgrade from installation server) and HKLM\SOFTWARE\Wow6432Node\SAP\SAP Shared\SAPsourcedir but still the error occurs.

I also tried to put a local saplogon.ini in C:\Users\Default User\AppData\Roaming\SAP\Common but it doesn't work either.

Does anyone have a hint to solve this problem? Any help will be appreciated.

Kind regards

Jann

sap_citrix.png (10.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 29, 2013 at 12:30 PM

    The issue is resolved.

    The fault was, that the call of the saplogon.exe in the Citrix Admin Console was set to "C:\<path>\saplogon.exe /ini_file="http://<server>\SapLogonTree.xml" instead of the .ini file.

    Thank you anyway.

    Jann

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 16, 2013 at 12:32 PM

    Hello Jann,

    Did you review note

    Ensure that the location of the file is in a reacable location and is not set to read-only.

    http://service.sap.com/sap/support/notes/1426178

    Kind Regards,

    Jude

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Jude

      I set the permission to read-write but still the problem exists. I also re-checked if the URL is reachable and if the locations is set by registry.

      Do you have another idea?

      Kind regards

      Jann

  • avatar image
    Former Member
    Aug 16, 2013 at 08:18 AM

    FYI: We use SAP GUI 7.30 with SP5.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 03, 2014 at 10:57 AM

    Hi,
    I was having the same problem i.e.

    "Error while loading local configuration files:

    Name of tree structure file http://<server>/SapLogonTree.xml invalid.
    local configuration used."


    I did all the required steps as said by you guys but the problem still persisted.

    The solution to was that my antivirus "symantec endpoint" had disabled its access.
    which i enabled going to symentec network protection and then to application status, to change the settings.

    Thanks
    Akash Verma

    Add comment
    10|10000 characters needed characters exceeded