Skip to Content
0
Former Member
Aug 15, 2013 at 02:45 AM

Transformation Validation Failure

45 Views

Hi,

I am tyring to validate my transformation file with an extract from BW.

We have built a BW extract to be in the same format as the existing ECC extract (same headers, tab delimited, etc.), so that we can leverage our existing transformation files to import the data. The extract is written such that it saves the file directly to the legal consolidations shared folder. From there it can be imported into the legal cons model in BPC, which I have been able to do without any major issues. Then I upload this file in EPM, to the management consolidations model. When I try validating the management transformation file everything looks good in the status (options, mappings, conversion, validate records) untill at the end of the file under Validate Records = YES, it shows the following:

[F@!1]

Validaton with data file failed.

The rejected list is blank, and I cannot find any trace of this error in service market place

Further when I actually run the import, it fails in 3 seconds.

The detail log says:

Total Step: 2

Convert Data: Failed in 3 Seconds

Import: Completed in 3 sec

Then it does not say much else, but [F !] at the end of the log......

It must have something to do with the file, even though it appears to be in the same format as all of my other files that work. I have tried several different workarounds.

Some of the things I've tried were:

- copied and pasted the format from one of the ECC extracts - unsuccessful

- validated the transformation file with one of the ECC extracts - successful

- deleted everything but the first row of data in the file - successful, 1 record was imported

- deleted everything at the end of the file - unsuccessful

- used specific mapping in the options section - unsuccessful, returned "*head dimension count and data column count are not matched"

Please let me know if you have any questions or comments. Thanks in advance for your insight.

Kevin