Skip to Content

SAPCAR issue

Hi experts,

I'm trying to install NWDS for development of PI Mail adapter custom module.

We're running on PI 7.02 SP12 and I've downloaded JIDE12_0-10002804.SAR from Markeplace (where it says SAP Netweaver Developer Studio 2.0 SP12).

Afterward I've downloaded SAPCAR 7.01 - Windows on x64 64bit (I'm using Win7 64bits) as I didn't see any SAPCAR for 7.02, only 4.6, 6.20, 7.00, 7.01, 7.20.

I faced some issues in the prompt to start the JIDE12xxx.SAR unpacking:

1 -  'SAPCAR' is not recognized as an internal or external command,

operable program or batch file. (this thread fixed http://scn.sap.com/thread/398418).

2 -  SAPCAR: could not open for writing ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.sap.ide.webdynpro.checklay

er/docs/api/com/sap/ide/webdynpro/checklayer/componentcontrollerusage/ComponentControllerUsageChecke

r.html (error 28). The system cannot find the path specified. (these threads fixed https://scn.sap.com/thread/1963099 and http://scn.sap.com/thread/2143327) also this one helped http://www.easymarketplace.de/SAPCAR.php.

I was using JRE 1.6 and have downgraded to 1.4.2_19 but now I'm getting the following error:

"x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2ee.viewmaps/plugin.jar

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2ee.viewmaps/plugin.properties

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2ee.viewmaps/plugin.xml

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2ee.viewmaps.java

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2ee.viewmaps.java/plugin.jar

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2ee.viewmaps.java/plugin.properties

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2ee.viewmaps.java/plugin.xml

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2se.doc.user_1.3.1

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2se.doc.user_1.3.1/doc.zip

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2se.doc.user_1.3.1/plugin.properties

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2se.doc.user_1.3.1/plugin.xml

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2se.doc.user_1.3.1/toc.xml

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2se.doc.user_1.4.2

x ./J2EE-RUNT-CD/IDE/eclipse/plugins/com.tssap.j2se.doc.user_1.4.2/doc.zip

SAPCAR: error reading from JIDE12_0-10002804.SAR (error 5)."

I didn't find anything to help with this.

Can anyone give a help?

Tks a lot!

Rafael.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Aug 13, 2013 at 07:26 PM

    Hi Rafael,

    It's safe to use sapcar 7.20 for NW 7.02.

    As for the error you are getting: it sounds as if the input archive JIDE12_0-10002804.SAR is corrupt. Maybe the download was not completed correctly.

    I suggest to:

    - download sapcar 7.20 and try again

    - check the integrity of the archive with sapcar -df

    - download the archive again

    Regards,

    Tobias

    Add comment
    10|10000 characters needed characters exceeded

    • Downloaded the right version of SAPCAR component (JIDE12_0-10006656.SAR) and also, there was a problem with the old file I've downloaded.

      So I used SAP Download Manager to download the correct file version and it worked.

      Tks a lot for all the help!

      Rafael.

  • Aug 13, 2013 at 11:15 PM

    Hi,

    Have you tryed to run SAPCAR as Administrator? run CMD as Administrator? Windows is sometimes tricky. Hope it helps!

    Cheers!

    Add comment
    10|10000 characters needed characters exceeded