Skip to Content
avatar image
Former Member

How to Hide a Prompt coming from Bex in Webi Report

Hi BOBJ experts,

I have a Report1 in Webi 4.0 built directly on Bex1.

There is a optional Prompt in Bex which is appearing in Webi Report1 Prompt. User wants this to be hidden.

How can I hide it?

Note: I cannot remove the prompt from Bex as other Webi reports are built on this same bex query. This optional filter needs to be removed only in Report1

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 19, 2013 at 07:00 AM

    When you are in the edit query mode, go to the variables settings.

    Once in there you will be able to deselect the box for “Set as Prompt” for that particular line. 

    If you just do this and try to save it wont work.  

    You need to enter data in the mandatory prompts.  We will get rid of these default values when we purge prompts step before saving the query.


    prompt.png (46.2 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 14, 2013 at 06:16 AM

    Thank you all for your answers.

    SPecial Thanks to Prathiban for giving correct solution:)

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ingo,

      Yes, I got your point and I know that if you leave optional prompt with out any values the reports runs wide open. That's how we can logically say "Hide the prompt".

      Just wanted to understand Parthiban and Deepthi solution, in my case "OK" button is disabled after unchecking the prompt.

      Thanks,

      Jothi

  • Aug 13, 2013 at 12:56 PM

    Hello Deepthi,

    your data source has a prompt, so your report won't hide it.

    if you don't want to use a prompt then you would have to change the underlying data source.

    regards

    Ingo Hilgefort

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 13, 2013 at 01:00 PM

    Hi,

    Unfortunately you have to copy the bex and remove the variable then change the datasource as the copied bex in report1 in my opinion.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 13, 2013 at 01:39 PM

    Hi,

    Kindly disable the below option and try:

    Set Variables->Set as prompt

    1. Click Set Variables

    2. Uncheck Set as Prompt

    Thanks,

    Parthiban


    Add comment
    10|10000 characters needed characters exceeded

    • hi guys,

      the "hide" will only work if the BEx variable is optional and then the report will return all values.

      if you do not want the report to leverage a prompt, then you should remove the BEx variable from the underlying BEx query.

      regards

      Ingo Hilgefort

  • Aug 13, 2013 at 03:08 PM

    Hi,

    If Bex is the data source then you wouldn't be able to check the option.

    as Ingo suggested, Pls update BEx query accordingly.

    Thanks,

    Jothi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 14, 2013 at 02:45 PM

    That was optional prompt i wanted to hide, so it works.

    Jyothirmayee : I am using BO 4.0 as well but it works, please follow the screenshots and i guess it will only work for optional prompt

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      You mean to say that in Webi query browser properties you could actually set the BEx optional prompt uncheck?.

      Can you post your screen shot and also the OK button if it is highlighted?. I'm really interested to know this.

      Thanks,

      Jothi