Skip to Content

Solution Manager 7.1 installation failing

Hello,

I am trying to install Solution Manager 7.1 on Oracle 10.2 and Linux. Unfortunately, at the very beginning of the installation, I am getting

a very bizzare error, during creating the users for the SAP system, here is an excerpt from my sapinst.log file:

TRACE  2013-08-05 20:47:30.334 [syuxctask.cpp:880]        CUnixProcessManager::sap_waitpid(pid_t pid, int * pStatus, int options)        lib=syslib module=syslib

Child process 5284 returned 0

ERROR  2013-08-05 20:47:30.355 [sixxcstepexecute.cpp:916]

FCO-00011  The step setUserEnvironment with step key |NW_Users_Create|ind|ind|ind|ind|0|0|NW_Users_Create_Do|ind|ind|ind|ind|usersCreateDo|0|setUserEnvironme

nt was executed with status ERROR ( Last error reported by the step: Assertion failed: in

function (role, readAccountData) {

if (readAccountData === undefined) {     readAccountData = true; } NWUsers.trace("NWUsers.getAccountData(", role, ")"); this._initAccountData(); ASSERT(arguments.callee, this.haveAccountData(role), "role " + role + " is not created yet."); var ad = this._readAccountDataFromKeydb(role); if (readAccountData) {     ad = this._readAccountData(ad); } var masterpwd = this.getMasterPassword(); if (ad.password == "" && this._useMasterPasswordForAccountData(ad) && ad.type == "USER" && masterpwd !== undefined && role != NWUsers.roles.J2EEGuest &&

!ad.locked) {

    ad.password = masterpwd; } NWUsers.trace("NWUsers.getAccountData(): ", dump_properties(ad)); return ad;

}

role ORA_SID is not created yet.).

TRACE  2013-08-05 20:47:30.380 [kdxxctaco.cpp:165]        CKdbTableContainerImpl::syncToContainerFile lib=iakdblib

CKdbTableContainerImpl::syncToContainerFile start ...

TRACE  2013-08-05 20:47:30.420 [kdxxctaco.cpp:197]        CKdbTableContainerImpl::syncToContainerFile lib=iakdblib

after creating out stream

I've tried to google, but no help, Note 972263 - Inst.NW 7.0(2004s)SR2/Business Suite 2005 SR2-UNIX/Oracle is not helpful either.

I've tried to run solely the preparation option for user creation. No luck :-/

I am  installing using the latest version of the SWPM, so I guess this shouldn't be some JVM issue... PLEASE HELP !!!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 11, 2013 at 10:03 AM

    Hi simon,

    there is nothing to worry. this is an sap bug and the solution is provided in note 972263

    try the following

    There are two ways to resolve this problem:


  • Modify control.xml and restart the installation
    1. 1. Edit file control.xml in your installation directory (default

    sapinst_instdir).

      2. Search for "this.runCatproc = "

      3. Go to "script.execute_AbortOnFailure();" some lines below.

      4. Replace "script.execute_AbortOnFailure();" with "script.execute();".

      5. Restart Sapinst and choose "Continue with the Old Option"


  • Update the sapinst executable and restart the installation
    1. 1. Download the newest sapinst executable from the Software Distribution

    Center as follows:


      a) Go to
    http://service.sap.com/swdc.


      b) On the right-hand panel, choose "Search for Software".


      c) Enter "sapinst" as search term.


      d) Choose the sapinst executable for your release (640, 700, 710).

      2. Replace the existing sapinst executable with the downloaded sapinst

    executable

    1. 3. Restart Sapinst and choose "Continue with the Old Option"

    Regards,

    Nag

Add comment
10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 06, 2013 at 06:54 AM

    May I know the exact oracle version you are installing?

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 06, 2013 at 07:20 AM

    hi,

    error as,

    role ORA_SID is not created yet.).

    Try the sap note 1300538. the solution could be as below as per the sap note

    later i found this, chk this work arround too http://scn.sap.com/thread/3366486

    Thanks

    Jansi

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 06, 2013 at 07:20 PM

    Hi everybody,

    thanks for your replies and suggestions, unfortunately none of this could solve the problem:

    @Sudheer G - I am installing the original oracle 10.2, which is coming with SAP. I have Oracle patch 10.2.0.5 prepared to install during the installation.

    @Jansi Rani Murugesan - I found Note 1300538 yesterday. The proposed solution:

    Restart SAPinst using command line option SAPINST_SKIP_ERRORSTEP=true. On the "What do you want to do" screen, choose "Continue with the old option" returned exactly the same error.

    From the thread you sent me:

    ./sapinst IS_HOST_LOCAL_USING_STRING_COMPARE=true SAPINST_USE_HOSTNAME=<hostname>

    This doesn't work either, when I try it, I am getting the following error:


    Inconsistent value of property SAPINST_USE_HOSTNAME for toplevel component NW_Onehost|ind|ind|ind|ind. Previous value: '', current value: '<hostname>'.

    Perhaps this might be caused by the fact, that I've chosen not to do a domain installation ... ??

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Symon Braunbaer

      Hello,

      After adding these limits you have to trigger the command sysctl -p for the parameters to effective.

      Best Regads

      Bhupesh