Skip to Content
0
Former Member
Sep 19, 2005 at 03:29 PM

BPM- "System_Error">SOAP fault message received

65 Views

Hi,

Two days ago we upgraded SAP system from 4.7 to ERP2004.

We have designed the BPM in XI-3.0 which would receive data from SAP system via ABAP proxy and would make Synchronous call to SAP system to get other information.

It was working fine before upgrade in Production. It was also working fine in Dev and QA box of ERP2004.

But now we are getting error in when we receive data in BPM.

Following is the error:

Trace level="3" type="System_Error">SOAP fault message received</Trace>

<Trace level="3" type="System_Error">SOAP fault code: Client</Trace>

<Trace level="3" type="System_Error">SOAP fault string: Error during conversion of XI message</Trace>

<Trace level="2" type="T">Switch back to normalized party (HTTP response)</Trace>

I found the difference between the XML tag of the message which is describe below.

Before upgrade when message was successful.

<?xml version="1.0" encoding="utf-8" ?>

- http://bcm.edu/common" xmlns:xsi=" http://www.w3.org/2001/XMLSchema-instance">

<USRID>2_MA140016</USRID>

<USRID>CLARKSON</USRID>

</ns1:MT_ECA_USRID>

After upgrade when message is failed

<?xml version="1.0" encoding="utf-8" ?>

- http://bcm.edu/common">

<USRID>DIEGOL</USRID>

<USRID>DYEE</USRID>

</nr1:MT_ECA_USRID>

You would notice that

"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> is missing after upgrade.

Please help me if you understand above problem.

Thanks in advance!

Mrudula