Skip to Content
author's profile photo Former Member
Former Member

BPM- "System_Error">SOAP fault message received

Hi,

Two days ago we upgraded SAP system from 4.7 to ERP2004.

We have designed the BPM in XI-3.0 which would receive data from SAP system via ABAP proxy and would make Synchronous call to SAP system to get other information.

It was working fine before upgrade in Production. It was also working fine in Dev and QA box of ERP2004.

But now we are getting error in when we receive data in BPM.

Following is the error:

Trace level="3" type="System_Error">SOAP fault message received</Trace>

<Trace level="3" type="System_Error">SOAP fault code: Client</Trace>

<Trace level="3" type="System_Error">SOAP fault string: Error during conversion of XI message</Trace>

<Trace level="2" type="T">Switch back to normalized party (HTTP response)</Trace>

I found the difference between the XML tag of the message which is describe below.

Before upgrade when message was successful.

<?xml version="1.0" encoding="utf-8" ?>

- http://bcm.edu/common" xmlns:xsi=" http://www.w3.org/2001/XMLSchema-instance">

<USRID>2_MA140016</USRID>

<USRID>CLARKSON</USRID>

</ns1:MT_ECA_USRID>

After upgrade when message is failed

<?xml version="1.0" encoding="utf-8" ?>

- http://bcm.edu/common">

<USRID>DIEGOL</USRID>

<USRID>DYEE</USRID>

</nr1:MT_ECA_USRID>

You would notice that

"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> is missing after upgrade.

Please help me if you understand above problem.

Thanks in advance!

Mrudula

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 19, 2005 at 06:47 PM

    I figure out what the problem was!

    Mrudula

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 02, 2005 at 03:37 PM

    Hi,

    I'm facing a similar problem .. i'm sending data to an ABAP proxy and the trace shows the following:

    cant figure out whats happening...

    <Trace level="3" type="System_Error">SOAP fault message received</Trace>

    <Trace level="3" type="System_Error">SOAP fault code: Client</Trace>

    <Trace level="3" type="System_Error">SOAP fault string: Error during conversion of XI message</Trace>

    <Trace level="2" type="T">Switch back to normalized party (HTTP response)</Trace>

    How did you solve your problem?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.