Skip to Content

Performance issue with drill down

We have an MPOS where there was initially no issue in regards to performance during drill-down but when added three extra attributes: there suddenly came up an intense performance issue. Below are the points to be considered:

  1. Not many macros are written that are part of standard category [start, default, level change].
  2. No new key-figures are added to the data view.
  3. The problem is not in reference to a particular data view but with each of the planning area.
  4. Aggregates can work good, but a strange observation has what propelled me to pose this discussion:
    • there is no performance issue when drilled down with "Details All" on this newly created attribute,
    • and there is performance issue only when drilled down specific to a value of the attribute.

So, the point is: if there is really a performanc issue, why at all it should work good for "Details All", and create an issue when particularly disaggregating with a particular value?

Not definitely sure as to why this is the case: would like to have some light on this. Thank you all for your participation.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jul 31, 2013 at 12:12 AM

    Hello Guru, First please try updating indexes and statistics for your MPOS with report /SAPAPO/TS_PSTRU_TOOL. If it does not solve the problem, please take performance trace in ST12 which should be useful for your analysis. Without the trace, it's hard to guess ... If you need SAP's help, please create OSS message on this issue.

    Add comment
    10|10000 characters needed characters exceeded