Skip to Content

Error While Posting IDoc to ECC

Dear All,

Scenario: File to IDoc (PI 7.31)

We are getting below error in PI while posting IDoc in to ECC system.

Required Objects are created properly like RFC destination etc....

Also We have added "1" for the Fields Segment in all IDoc segments as per few suggestion but still its not working.

Note: We are using ICO and IDoc_AAE Adapter

Up.png (20.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Jul 30, 2013 at 10:49 AM

    Hi,

    Please check the below blog..

    http://scn.sap.com/thread/1901278

    If still not solved , pls check the config again.

    Thanks,

    satish

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 30, 2013 at 10:54 AM

    hi Manikanandan,

    Seems like the control record is not populated correctly. I assume it is a flat IDoc file to IDoc scenario so I think the control records are not populated correctly by source. Check the partner profile in ECC and try to manipulate the file manually to make it work.

    Then take it up with the source system for correction.

    hope it helps!

    Ambrish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 30, 2013 at 10:58 AM

    Hi,

    How are you generating the control record values of the idoc?

    Go to IDoc Monitoring and check in Pimon what all the control record values getting generated...

    provide more info on population of control record values..

    HTH

    Rajesh

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 30, 2013 at 11:03 AM

    hello,

    You error clearly suggest that u are not passing logical system name...

    So what u can do is:

    1) In ur mapping disable EDIDC40 segment

    2) Then use header mapping and assign "Sender Communication Component" name may be ur R3 business system name will suffice

    3) In idoc receiver channel do not check "Apply Control Records from Payload"

    4) In SAP system create a partner profile with the logical system name of the assigned above Business system (in this case it will be R3 logical system name)

    Second approach (simple one):

    1) Disable EDIDC40 segment

    2) Select Sender Business Component  name -> Click on Adapter Specific identifiers -> Assign value under "Logical system"

    3) In ECC system, define partner profile with the same name as the one you have mentioned in step 2

    Thanks

    Amit Srivastava

    Add comment
    10|10000 characters needed characters exceeded