Skip to Content
1

Eclipse ADT: Asterisk(*) tabulator autocomplete

Jan 11, 2017 at 02:32 PM

641

avatar image

Hello all,

while working with ABAP in Eclipse and writing a Asterisk (*) at the start of a line, I get an autocomplete proposal of 69 additional *.

Which is, of course, automaticly inserted with one press on tabulator.

Is it possible to disable this autocomplete proposal?

It seems like this proposal does not originate from the SAP System but is direktly embedded in the Eclipse Plugin, as I tried to debug into it but never got a debugger between writing the * and the proposal appearing. I looked through the Eclipse preferences but could not find a setting that would disable it.

Thanks in advance.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member
Jan 12, 2017 at 11:11 AM
0

Hi Tobias,

If you disable the keyword code completion under Preferences > ABAP Development > Editors > Source Code Editors > Code Completion > Suggest keywords, then the additional * will no longer be proposed.

A down side of this is that ABAP keywords will also no longer be proposed. For me personally this is not a problem since I always trigger code completion with CTRL+SPACE myself. This also works for ABAP keywords. For example, when I type "sele" and trigger code completion (CTRL+SPACE), then "select, select-options, selection-screen" is proposed. I can then insert the proposal with ENTER. I hardly ever use TAB for insertions. But this is a matter of "preference" ;-).

P.S. you can also just ignore the automatic proposal (additional *) by hitting the ESC key. Then you can use TAB to insert white spaces.

Regards

Chris

Share
10 |10000 characters needed characters left characters exceeded
Tobias Hey Jan 18, 2017 at 08:41 AM
0

Hi Chris,

I thought about doing that as well, but presently I still use TAB to autocomplete small things like TYPE or READ TABLE rather often. The use of CTRL+SPACE also seems to be a bit slow because it asks the SAP System for these propositions, which gets worse when connecting to a customer System through a VPN and such.

I was generally wondering why there is such a autocomplete for *. After all * works as as a comment symbol only at the start of the line, which is also the only place this autocomplete triggers. I guess with enough time working with it, I will internalized the press of ESC after writing * as a comment start. I just had the hope that it could be disabled easily, especially because it is used in my company rather often.

Regards

Tobias

Share
10 |10000 characters needed characters left characters exceeded