Skip to Content
avatar image
Former Member

Connect two SAP MII servers using virtual IDBC connectors

I need to connect two different SAP MII servers using virtual IDBC connetor.

The SAP MII servers are linked, but I am not able to write any query using this data connector. This is because the modes for this data connector is not visible while creating a query.

Have any one done this earlier?

Please help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jul 28, 2013 at 09:03 PM

    Also make sure permissions are correct for your use and roles.  Check the java console and server errors, you may be getting an error trying to call the ModeList query request in the editor.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Salvatore Castro

      Hello Sam,

      While trying to create a query template using this virtual connector, I am getting the error as: "Cannot Load Parameter Mode."

      We are using HTTP and please find the configuration screen shot below for this connector:

      Regards,

      Snehal

      Connect_7.JPG (48.2 kB)
      Connect_7.JPG (20.7 kB)
      Connect_8.JPG (151.0 kB)
  • avatar image
    Former Member
    Jul 26, 2013 at 01:27 PM

    Hi  Snehal,

    Please follow the steps:

    1) Log  into  Primary server and access Data services from MII portal :

         select   connector type as Virtual IDBC

         click on  settings tab

       b) check both the checkboxes ( Enabled, Allow dynamic query)

    2) provide the target MII server IP , Remote login server name and its credentials.

    3) Once you complete , please check the connection status.

    Note:  make sure there is no firewall in between two MII servers

    Regards,

    Suman

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Suman,

      I have followed the steps and now the SAP xMII 11.5 server is successfully configured in SAP MII 12.2. Also the status is showing as running.

      But still while I my using this connector to create a SQL query, I am not able to see the query modes to be selected. Please refer the screenshot below:

      I am not able to figure out exact problem.

      plz help.

      Regards,

      Snehal

      Connect_1.JPG (36.1 kB)
      Connect_2.JPG (59.9 kB)