Skip to Content
avatar image
Former Member

Log Volume is Full

Hi,

Log Volume is Full and the database doesn't accept any new requests.

I have tried to take backup but it is getting failed.

Please suggest what can be done?

Thanks,

Priya

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Jul 29, 2013 at 12:50 PM

    Hi Priya,

    Actually you need to make sure few things in live systems:

    • Make sure the automatic log backup is enabled.
    • You install HANA in log drive which has sufficient space available keeping into consideration future db growth. refer to HANA sizing guide for that.

    To resolve your issue, follow below:

    1. Open HANA Studio.

    2. Open SQL editor for your HANA system.

    3. Execute:

    alter system reclaim log;

    4. Take the backup.

    HAPPY HANA 😊

    Deepak Chodha.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 30, 2013 at 02:17 AM

    Hi Priya,

    If the log_mode is set to legacy the logvolume keeps all log segments since the last full backup in the logvolume. If no backups are performed the logvolume can run out of space.

    1. Stop the database:

    HDB stop

    2. Change into the folder mnt00001 of the logvolume (Default: /usr/sap/<SID>/global/hdb/log):

    cd /usr/sap/<SID>/global/hdb/log/mnt00001

    3. You have to move one of the logvolumes temporarily to another volume where enough space is available. You should free at least 2 GB of space to ensure that the database has enough space to start. To find out the space consumption of each volume execute:

    du -sh *

    4. Move a volume which consumes at least 2 GB of space (e.g. hdb00003) to a volume with enough free space, e.g. to the data volume (Default: /usr/sap/<SID>/global/hdb/data):

    mv hdb00003 /usr/sap/<SID>/global/hdb/data

    5. Create a symbolic link to the new folder in the old location:

    ln -s /usr/sap/<SID>/global/hdb/data/hdb00003 /usr/sap/<SID>/global/hdb/log/mnt00001/hdb00003

    6. Start the database (HDB start) and set the log_mode to 'overwrite' using the following SQL-Statement:

    ALTER SYSTEM ALTER CONFIGURATION ('global.ini', 'SYSTEM') SET ('persistence', 'log_mode') = 'overwrite' WITH RECONFIGURE;

    7. Restart the database (HDB restart) and use the following SQL-Statement to clean up the logvolume:

    ALTER SYSTEM RECLAIM LOG;

    8. Set back the log_mode to 'legacy' (you should consider switching to log_mode = normal; see note 1645183 for more information):

    ALTER SYSTEM ALTER CONFIGURATION ('global.ini', 'SYSTEM') SET ('persistence', 'log_mode') = 'legacy' WITH RECONFIGURE;

    9. Stop the database again and remove the symbolic link:

    rm -f /usr/sap/<SID>/global/hdb/log/mnt00001/hdb00003

    10. Move the log volume back to its original location:

    mv /usr/sap/<SID>/global/hdb/data/hdb00003 /usr/sap/<SID>/global/hdb/log/mnt00001

    11. Start the database and perform a backup.

    Thanks & Regards,

    V Srinivasan

    Add comment
    10|10000 characters needed characters exceeded

    • I encountered the same issue: DO NOT set 'legacy' log_mode after 74 (my system was SPS09). If the HANA system does not start, look for an error message in the nameserver log. To change the parameter, you'll need to edit the custom/config file since HANA Studio is not available.

      Donn

  • avatar image
    Former Member
    Jul 30, 2013 at 04:00 AM

    Hi,

    Please move some log segment to another file system and create a symbolic link to the original directory. It will allow the HANA to restart.

    Take a backup from Studio.


    After that try this command "ALTER SYSTEM RECLAIM LOG" to get free space in the log area.

    Thanks,

    Shashi

    Add comment
    10|10000 characters needed characters exceeded