Skip to Content
avatar image
Former Member

Dispatcher is stopped

Hi All,

I am facing a problem. The dispatcher got stopped. If I am restarting the instance, then dispatcher is getting started but after sometime its going down again.

Please, help me out.

This is my dev_disp trace file:

---------------------------------------------------

trc file: "dev_disp", trc level: 1, release: "720"

---------------------------------------------------

sysno 00

sid E6T

systemid 562 (PC with Windows NT)

relno 7200

patchlevel 0

patchno 100

intno 20020600

make multithreaded, Unicode, 64 bit, optimized

profile \\ae6tdb\sapmnt\E6T\SYS\profile\E6T_DVEBMGS00_ae6tdb

pid 2100

kernel runs with dp version 131000(ext=118000) (@(#) DPLIB-INT-VERSION-131000-UC)

length of sys_adm_ext is 588 bytes

*** SWITCH TRC-HIDE on ***

***LOG Q00=> DpSapEnvInit, DPStart (00 2100) [dpxxdisp.c 1287]

shared lib "dw_xml.dll" version 100 successfully loaded

shared lib "dw_xtc.dll" version 100 successfully loaded

shared lib "dw_stl.dll" version 100 successfully loaded

shared lib "dw_gui.dll" version 100 successfully loaded

shared lib "dw_mdm.dll" version 100 successfully loaded

shared lib "dw_rndrt.dll" version 100 successfully loaded

shared lib "dw_abp.dll" version 100 successfully loaded

shared lib "dw_sym.dll" version 100 successfully loaded

shared lib "dw_aci.dll" version 100 successfully loaded

rdisp/softcancel_sequence : -> 0,5,-1

use internal message server connection to port 3900

rdisp/dynamic_wp_check : 1

rdisp/calculateLoadAverage : 1

Fri Jul 19 16:39:04 2013

*** WARNING => DpNetCheck: NiAddrToHost(1.0.0.0) took 4 seconds

***LOG GZZ=> 1 possible network problems detected - check tracefile and adjust the DNS settings [dpxxtool2.c 6404]

MtxInit: 30000 0 0

DpSysAdmExtInit: ABAP is active

DpSysAdmExtInit: VMC (JAVA VM in WP) is not active

DpIPCInit2: write dp-profile-values into sys_adm_ext

DpIPCInit2: start server >ae6tdb_E6T_00 <

DpShMCreate: sizeof(wp_adm) 31696 (2264)

DpShMCreate: sizeof(tm_adm) 5517056 (27448)

DpShMCreate: sizeof(wp_ca_adm) 64000 (64)

DpShMCreate: sizeof(appc_ca_adm) 64000 (64)

DpCommTableSize: max/headSize/ftSize/tableSize=500/16/584064/584080

DpShMCreate: sizeof(comm_adm) 584080 (1144)

DpSlockTableSize: max/headSize/ftSize/fiSize/tableSize=0/0/0/0/0

DpShMCreate: sizeof(slock_adm) 0 (104)

DpFileTableSize: max/headSize/ftSize/tableSize=0/0/0/0

DpShMCreate: sizeof(file_adm) 0 (80)

DpShMCreate: sizeof(vmc_adm) 0 (2152)

DpShMCreate: sizeof(wall_adm) (41664/36752/64/192)

DpShMCreate: sizeof(gw_adm) 48

DpShMCreate: sizeof(j2ee_adm) 3952

DpShMCreate: SHM_DP_ADM_KEY (addr: 00000000035A0050, size: 6357408)

DpShMCreate: allocated sys_adm at 00000000035A0060

DpShMCreate: allocated wp_adm_list at 00000000035A3040

DpShMCreate: allocated wp_adm at 00000000035A3230

DpShMCreate: allocated tm_adm_list at 00000000035AAE10

DpShMCreate: allocated tm_adm at 00000000035AAE60

DpShMCreate: allocated wp_ca_adm at 0000000003AEDD70

DpShMCreate: allocated appc_ca_adm at 0000000003AFD780

DpShMCreate: allocated comm_adm at 0000000003B0D190

DpShMCreate: system runs without slock table

DpShMCreate: system runs without file table

DpShMCreate: allocated vmc_adm_list at 0000000003B9BB30

DpShMCreate: system runs without vmc_adm

DpShMCreate: allocated gw_adm at 0000000003B9BBE0

DpShMCreate: allocated j2ee_adm at 0000000003B9BC20

DpShMCreate: allocated ca_info at 0000000003B9CBA0

DpShMCreate: allocated wall_adm at 0000000003B9CC30

DpCommAttachTable: attached comm table (header=0000000003B0D190/ft=0000000003B0D1A0)

DpSysAdmIntInit: initialize sys_adm

rdisp/test_roll : roll strategy is DP_NORMAL_ROLL

dia token check not active (5 token)

MBUF state OFF

DpCommInitTable: init table for 500 entries

DpRqQInit: keep protect_queue / slots_per_queue 0 / 2001 in sys_adm

rdisp/queue_size_check_value : -> on,50,30,40,500,50,500,80

EmInit: MmSetImplementation( 2 ).

MM global diagnostic options set: 0

<ES> client 0 initializing ....

<ES> InitFreeList

<ES> block size is 4096 kByte.

<ES> Info: em/initial_size_MB( 3838MB) not multiple of em/blocksize_KB( 4096KB)

<ES> Info: em/initial_size_MB rounded up to 3840MB

Using implementation view

<EsNT> Using memory model view.

<EsNT> Memory Reset disabled as NT default

<ES> 959 blocks reserved for free list.

ES initialized.

mm.dump: set maximum dump mem to 96 MB

DpVmcSetActive: set vmc state DP_VMC_NOT_ACTIVE

MPI: dynamic quotas disabled.

MPI init: pipes=4000 buffers=1279 reserved=383 quota=10%

rdisp/http_min_wait_dia_wp : 1 -> 1

***LOG CPS=> DpLoopInit, ICU ( 4.0.1 4.0.1 5.1) [dpxxdisp.c 1673]

***LOG Q0K=> DpMsAttach, mscon ( ae6tdb) [dpxxdisp.c 12339]

MBUF state LOADING

DpStartStopMsg: send start message (myname is >ae6tdb_E6T_00 <)

DpStartStopMsg: start msg sent

CCMS uses Shared Memory Key 73 for monitoring.

CCMS: AlInitGlobals : alert/use_sema_lock = TRUE.

CCMS: Initalized shared memory of size 60000000 for monitoring segment.

CCMS: Checking Downtime Configuration of Monitoring Segment.

CCMS: AlMsUpload called by wp 1024.

Fri Jul 19 16:39:06 2013

CCMS: AlMsUpload successful for D:\usr\sap\E6T\DVEBMGS00\log\ALMTTREE.DAT (3537 MTEs).

Fri Jul 19 16:39:07 2013

CCMS: start to initalize 3.X shared alert area (first segment).

DpMBufHwIdSet: set Hardware-ID

***LOG Q1C=> DpMBufHwIdSet [dpxxmbuf.c 1296]

MBUF state ACTIVE

DpWpBlksLow: max wp blocks in queue is 800 (80 %)

MBUF component UP

DpMsgProcess: 1 server in MBUF

DpAppcBlksLow: max appc blocks in queue is 500 (50 %)

Fri Jul 19 16:39:21 2013

DpModState: change server state from STARTING to ACTIVE

Fri Jul 19 16:41:55 2013

***LOG Q1O=> DpWpConf, WP Conf () [dpxxdisp.c 14526]

DpWpConf: change reqtype of W7 from BTC to DIA

***LOG Q0V=> DpWpConf, mod_req ( 7BTCDIA) [dpxxdisp.c 15110]

DpAdaptWppriv_max_no : 1 -> 1

Fri Jul 19 23:00:25 2013

***LOG Q1O=> DpWpConf, WP Conf () [dpxxdisp.c 14526]

DpWpConf: change reqtype of W7 from DIA to BTC

***LOG Q0V=> DpWpConf, mod_req ( 7DIABTC) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W4 from DIA to BTC

***LOG Q0V=> DpWpConf, mod_req ( 4DIABTC) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W3 from DIA to BTC

***LOG Q0V=> DpWpConf, mod_req ( 3DIABTC) [dpxxdisp.c 15110]

DpAdaptWppriv_max_no : 1 -> 1

Sat Jul 20 09:00:25 2013

***LOG Q1O=> DpWpConf, WP Conf () [dpxxdisp.c 14526]

DpWpConf: change reqtype of W9 from BTC to DIA

***LOG Q0V=> DpWpConf, mod_req ( 9BTCDIA) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W8 from BTC to DIA

***LOG Q0V=> DpWpConf, mod_req ( 8BTCDIA) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W7 from BTC to DIA

***LOG Q0V=> DpWpConf, mod_req ( 7BTCDIA) [dpxxdisp.c 15110]

DpAdaptWppriv_max_no : 1 -> 1

Sat Jul 20 23:00:25 2013

***LOG Q1O=> DpWpConf, WP Conf () [dpxxdisp.c 14526]

DpWpConf: change reqtype of W9 from DIA to BTC

***LOG Q0V=> DpWpConf, mod_req ( 9DIABTC) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W7 from DIA to BTC

***LOG Q0V=> DpWpConf, mod_req ( 7DIABTC) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W2 from DIA to BTC

***LOG Q0V=> DpWpConf, mod_req ( 2DIABTC) [dpxxdisp.c 15110]

DpAdaptWppriv_max_no : 1 -> 1

Sun Jul 21 09:00:25 2013

***LOG Q1O=> DpWpConf, WP Conf () [dpxxdisp.c 14526]

DpWpConf: change reqtype of W9 from BTC to DIA

***LOG Q0V=> DpWpConf, mod_req ( 9BTCDIA) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W7 from BTC to DIA

***LOG Q0V=> DpWpConf, mod_req ( 7BTCDIA) [dpxxdisp.c 15110]

DpWpConf: change reqtype of W4 from BTC to DIA

***LOG Q0V=> DpWpConf, mod_req ( 4BTCDIA) [dpxxdisp.c 15110]

DpAdaptWppriv_max_no : 1 -> 1

------------------ C-STACK ----------------------

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

8 Answers

  • Jul 22, 2013 at 04:20 AM

    Hi Sudhir,

    As per provided information it seems issue with kernel,please update your kernel.
    Pleaase provide the more log , dev_w* dev_ms..

    BR
    Atul

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Reagan Benjamin

      Hi Benjamin,

      As you said, I have just executed the R3trans under e6tadm and the output is :

      This is my trans.log file below:

      4 ETW000 r3trans version 6.22 (release 720 - 03.06.11 - 17:57:00).

      4 ETW000 unicode enabled version

      4 ETW000 ===============================================

      4 ETW000

      4 ETW000 date&time : 22.07.2013 - 14:47:03

      4 ETW000 control file: <no ctrlfile>

      4 ETW000 R3trans was called as follows: r3trans -x

      4 ETW000 trace at level 2 opened for a given file pointer

      4 ETW000 [ dev trc,00000] Mon Jul 22 14:47:04 2013 104 0.000104

      4 ETW000 [ dev trc,00000] db_con_init called 38 0.000142

      4 ETW000 [ dev trc,00000] set_use_ext_con_info(): rsdb/ssfs_connect not set => ssfs not used 49 0.000191

      4 ETW000 [ dev trc,00000] determine_block_commit: no con_hdl found as blocked for con_name = R/3

      4 ETW000 30 0.000221

      4 ETW000 [ dev trc,00000] create_con (con_name=R/3) 18 0.000239

      4 ETW000 [ dev trc,00000] Loading DB library 'dbmssslib.dll' ... 45 0.000284

      4 ETW000 [ dev trc,00000] DlLoadLib success: LoadLibrary("dbmssslib.dll"), hdl 0, addr 000007FEEDA90000

      4 ETW000 1882 0.002166

      4 ETW000 [ dev trc,00000] using "D:\usr\sap\E6T\SYS\exe\uc\NTAMD64\dbmssslib.dll" 19 0.002185

      4 ETW000 [ dev trc,00000] Library 'dbmssslib.dll' loaded 24 0.002209

      4 ETW000 [ dev trc,00000] function DbSlExpFuns loaded from library dbmssslib.dll 21 0.002230

      4 ETW000 [ dev trc,00000] Version of 'dbmssslib.dll' is "720.00", patchlevel (0.98) 136 0.002366

      4 ETW000 [ dev trc,00000] function dsql_db_init loaded from library dbmssslib.dll 27 0.002393

      4 ETW000 [ dev trc,00000] function dbdd_exp_funs loaded from library dbmssslib.dll 20 0.002413

      4 ETW000 [ dev trc,00000] New connection 0 created 36 0.002449

      4 ETW000 [ dev trc,00000] 0: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , bc = NO , hc = NO , perm = YES, reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO , prog =

      4 ETW000 43 0.002492

      4 ETW000 [ dev trc,00000] db_con_connect (con_name=R/3) 21 0.002513

      4 ETW000 [ dev trc,00000] determine_block_commit: no con_hdl found as blocked for con_name = R/3

      4 ETW000 25 0.002538

      4 ETW000 [ dev trc,00000] find_con_by_name found the following connection: 17 0.002555

      4 ETW000 [ dev trc,00000] 0: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , bc = NO , hc = NO , perm = YES, reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO , prog =

      4 ETW000 35 0.002590

      4 ETW000 [ dev trc,00000] Thread ID:6064 978 0.003568

      4 ETW000 [ dev trc,00000] Thank You for using the SLODBC-interface 26 0.003594

      4 ETW000 [ dev trc,00000] Using dynamic link library 'D:\usr\sap\E6T\SYS\exe\uc\NTAMD64\dbmssslib.dll'

      4 ETW000 33 0.003627

      4 ETW000 [ dev trc,00000] dbmssslib.dll patch info 43 0.003670

      4 ETW000 [ dev trc,00000] SAP patchlevel 0 19 0.003689

      4 ETW000 [ dev trc,00000] SAP patchno 100 75 0.003764

      4 ETW000 [ dev trc,00000] Last MSSQL DBSL patchlevel 0 26 0.003790

      4 ETW000 [ dev trc,00000] Last MSSQL DBSL patchno 98 19 0.003809

      4 ETW000 [ dev trc,00000] Last MSSQL DBSL patchcomment Convert RAW input parameters to literals (1611849)

      4 ETW000 37 0.003846

      4 ETW000 [ dev trc,00000] ODBC Driver chosen: SQL Server Native Client 10.0 native 367 0.004213

      4 ETW000 [ dev trc,00000] lpc:(local) connection used on ae6tdb 120 0.004333

      4 ETW000 [ dev trc,00000] ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2292]

      4 ETW000 54685 0.059018

      4 ETW000 [ dev trc,00000] (18452) [28000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

      4 ETW000 39 0.059057

      4 ETW000 [ dev trc,00000] ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2292]

      4 ETW000 5816 0.064873

      4 ETW000 [ dev trc,00000] (18452) [28000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

      4 ETW000 53 0.064926

      4 ETW000 [ dev trc,00000] ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2292]

      4 ETW000 5655 0.070581

      4 ETW000 [ dev trc,00000] (18452) [28000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

      4 ETW000 39 0.070620

      4 ETW000 [ dev trc,00000] ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2292]

      4 ETW000 6804 0.077424

      4 ETW000 [ dev trc,00000] (18452) [28000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

      4 ETW000 39 0.077463

      4 ETW000 [ dev trc,00000] ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2292]

      4 ETW000 5622 0.083085

      4 ETW000 [ dev trc,00000] (18452) [28000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

      4 ETW000 40 0.083125

      4 ETW000 [ dev trc,00000] ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2292]

      4 ETW000 5633 0.088758

      4 ETW000 [ dev trc,00000] (18452) [28000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

      4 ETW000 40 0.088798

      4 ETW000 [ dev trc,00000] Connection 0 failed using Driver={SQL Server Native Client 10.0};Server=AE6TDB;AutoTranslate=no;Trusted_Connection=yes;WSID=ae6tdb;APP=R3 00 comm rd ODBC;Database=E6T;

      4 ETW000 53 0.088851

      4 ETW000 [ dblink ,00000] ***LOG BY2=>sql error 18452 performing CON 321 0.089172

      4 ETW000 [ dblink ,00000] ***LOG BY0=>[Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

      4 ETW000 43 0.089215

      2EETW169 no connect possible: "DBMS = MSSQL --- SERVER = 'AE6TDB' DBNAME = 'E6T'"

      R3trans.png (17.1 kB)
  • avatar image
    Former Member
    Jul 22, 2013 at 04:21 AM

    Hi , Sudhir can you plz share the dispatcher stop screen......

    Thanks

    Nikh

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 22, 2013 at 05:19 AM

    Hi Sudhir,

    There is some network issue as dispatcher cannot connect to Message server.

    Maintain the host name in host file if not present.

    or

    take a reboot of the server.

    With Regards

    Ashutosh Chaturvedi

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 22, 2013 at 05:42 AM

    Hi,

    Please check following,

    1. The database is Up. R3trans -d or R3trans -x

    2. Check Log area is not full.

    3. Verify your host file entry as Sudhir mentioned.

    4. If you have upgraded kernel make sure that files are copied to other directories also.

    Regards

    Jithin M

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 22, 2013 at 06:28 AM

    Can you attach full dev_disp log file?

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 22, 2013 at 07:11 AM

    Hi,

    The dispatcher is stopped because all work processes died.

    There is nothing done with message server.

    In work process trace file, it shows database connection error.

    B ***LOG BY2=> sql error 18452 performing CON [dbsh 1246]

    B ***LOG BY0=> [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. [dbsh 1246]

    You need to check if your database server and SAP server are running under the same domain.

    If yes, I recommend you try to re-register the server machines to the AD and see how it goes.

    Thanks.

    Jim

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 22, 2013 at 07:23 AM

    Hi,

    Please try to start your system with a correct domain account.

    Then this should work.

    Also, check this http://support.microsoft.com/kb/555332

    Regards,

    Divyanshu

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 22, 2013 at 09:59 AM

    Hello

    4 ETW000 [ dev trc,00000] ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2292]

    4 ETW000 54685 0.059018

    4 ETW000 [ dev trc,00000] (18452) [28000] [Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.

    4 ETW000 39 0.059057

    The problem is connection to the database.

    Did you make any changes to the hosts file ?

    Regards

    RB

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      It looks like the database doesn't recognize you are on the same domain. Did you put the fully qualified domain name in the hosts file, or just the short name?