Skip to Content
avatar image
Former Member

Cannot see the Service Interface in Directory Configuration

Hi everyone,

I create a Service Interface in the repository.

This  Service Interface is Outbound and activated.

In Directory Configuration, I created a Business Component.

In the Sender tab, I want to add the Service Interface but it doesn't appear in the list.

My version of PI is 7.31.

Thanks for the help.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

12 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 18, 2013 at 03:44 PM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 18, 2013 at 12:49 PM

    Hi,

    It is activated and I choose the any option and still does not see it.

    Does it have to do with landscape that should rely between Repository and Directory Configuration?

    Thanks for the blog, it is helpfull.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Muniyappan Marasamy

      Yes it is the first time.

      It is quite a headache for a novice.

      I will speak the basis team and keep you updated.

      Thanks a lot for the precious help.

      Regards.

  • Jul 18, 2013 at 11:58 AM

    Hello,

    If your object is activated then it should come...may be while searching for SI under ID change the category to "Any" and then check?

    Thanks

    Amit Srivastava

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 18, 2013 at 12:03 PM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 18, 2013 at 12:04 PM

    Hi David,

    Please change the drop down to "any", then you will be able to see your SI.

    Thanks,

    Naveen

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 19, 2013 at 01:20 AM

    Hello David,

    Sometimes the interface name is not showed up in PI. It is not related to SLD cache or anything else.

    Just manually type in your interface name or Copy/paste and complete your scenario. It will not throw any error and will work fine.

    Thanks

    Gaurav

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 18, 2013 at 12:02 PM

    Probably its not activated, expand your search as Amit suggested before and u may get it there if you have been activated it.

    Regards,

    Sunil

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 18, 2013 at 08:19 PM

    Hello David,

    Check the solution in note 1671958 PI 7.3 Integration Builder objects not visible. Does the 'com.sap.aii.ibrep.core.usage_type' parameter have the expected value?

    Regards

    Mark

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 19, 2013 at 06:28 AM

    Hi David,

    give a try  Gaurav Ranjan s idea.

    check if your scenario is working or not.

    Regards,

    Muniyappan.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 19, 2013 at 09:24 AM

    Hi David,

    Hope you are considering   case sensitive , if not give the exact case while you created.

    Still you can't then try giving manually , it should work.

    Thanks,

    Satish

    Add comment
    10|10000 characters needed characters exceeded