Skip to Content
avatar image
Former Member

RFCs started from job in dialog

Hi,

when run the job in background (prg. RSARFCEX), it calls internally RFCs in dialog and theese dialogs runs accidentally in other application server than the job is running.

It is possible to tell  to the dialog RFCs, where should be run? (on specified application server only?) and if so, where can I specify it?

Thaks in advance

zdenek bittner

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 18, 2013 at 09:49 PM

    Hi Zdenek,

    I think I've got an idea how you can solve this issue.

    Let's say your instance have 3 SAP Servers (CI/AS), A, B and C. Let's assume you will schedule your job on a fixed destination, server A. And I assume you know how long this job should run approximately, let's say 2 hours and the scheduled time is daily at 21:00.

    What you should do:

    • Create a "special, daily" Operation Mode for servers B & C, which make sure that daily between 20:30-23:30 (slightly more than those 2 hours jobs as an example, or less, up to you) on these servers there will be NO DIALOG workprocess running. You can set them to background workprocess for example. After that it will switch to "normal/existing" Operation Mode.

    This will make sure that during the job running-time, there is only 1 server (A) who has DIA-workprocess, and this is where the job itself is running at that time.

    I hope this will help you.

    Regards,

    Andre

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 18, 2013 at 09:02 AM

    Hi Zdenik,

    Why not just fix the rfc that it works on all the application server ?

    Best Regards

    Marius

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Don't forget to mark your post as the "correct/helpful/assumed answered" answer, so future viewers know what resolved the issue.

  • Jul 18, 2013 at 08:53 AM

    Hi Bittner,

    While defining the background job ,you can provide desired application server to run JOB .

    It will help you.

    BR

    Atul

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      this does not work - I tried before create this issue.

      The job hes the destination server specified, but the dialog RFCs starting on another application server (which is not even in any logon or FRC group).

      Regards

      zdenek

  • avatar image
    Former Member
    Jul 18, 2013 at 08:58 AM

    Hi ,

    Have you tried specifying the Application server in Exec target while scheduling the job? It will ensure that the job will run in that particular application server , and hopefully the selection of dialog would happen there only ..

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 18, 2013 at 10:59 AM

    Hello

    You can use server groups for background processing. Tx SM61.

    Additionally if there is an RFC connection used then check whether there is load balancing enabled and the logon group used here to balance the load.

    Check the AS's that are part of the logon group - Tx SMLG

    Also check the RFC Server Group Maintenance - RZ12

    Regards

    RB

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      we dont use  load balancing  (i.e. no logon group in SMLG).

      In RZ12 the appserver, which RFCs started on , is not included in any logon group.

      So we had assumed this app-server is not accessed by any process (so no dialog RFCs will be started on it).