Skip to Content

F4 Help is not available in infoset query.

Hi Experts,

I have created one Infoset and query using logical database IOC. This is for Production order information system.

In my selection screen of query i am getting system status field(by default from SAP) but no standard F4 help is available automatically.

How can i resolve this issue?

Please help.

below are the screen shots.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Jul 13, 2013 at 08:31 AM

    Try adding this filed (Sys Status) in selection screen throguh Infoset --> Extras--> Selection tab.

    Example:

    Try creating this field (like the fields shown in red box) by clicking on the NEW icon.

    While creating give the tablename-fieldname of system status in the place shown above.

    Like TJ30T-ISTAT

    I remember this worked during such situations. May try.

    Jogeswara Rao K


    Capture.JPG (93.9 kB)
    Capture.JPG (43.4 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member K Jogeswara Rao

      Hi Jogeswara,

      I have tried to apply your solution in the context of using the Logical Database IOC.

      I have checked that the parameter "P_SYST1" is present at the level 30 in the selection tab.

      I have created the "P_SYST" as you explain,

      I have changed the "START-OF-SELECTION" by adding the P_SYST1 = P_SYST.

      But when i tried to generate the infoset i received an error telling me that the field P_SYST1 is unknown and thereis a similiar field P_SYST.

      Could you help me because i don't know what i missed.

      Thanks.

      Best regards.

      Christophe.

  • author's profile photo Former Member
    Former Member
    Posted on Jan 11, 2016 at 01:00 PM

    Hi All,

    help on the infoset F4 help.

    I have created a infoset and trying to access this with analysis for office. Once i generate the infoset the F4 help is available in the prompt screen of the analysis for office. Once the session is gone, then re-login is not giving me anything.

    Do i am missing something(code part) or what exactly the generate option is doing over here.

    Thanks

    Gaurav

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.