Skip to Content
0
Former Member
Jul 12, 2013 at 02:05 PM

ECC 5.00 system copy, database instance installation error MDB-07004 "File not found C:\Program Files\sdb\globalprograms\pgm\dbmcli.exe"

29 Views

Dear experts,

I try to do a system copy from our old ECC 5.00 (Win2k3, 32bit) to a Win2k8RC2, 64bit. I already got the central instance installation done.

Now I got an installation error when trying to install the database instance. Following is the error message:

ERROR 2013-07-12 15:26:53

MDB-07004 File not found: "C:\Program Files\sdb\globalprograms\pgm\dbmcli.exe".

ERROR 2013-07-12 15:26:53

CJS-00030 Assertion failed: in function sapdb_db_create(db_nm, db_host, db_ver) { var dep_root = sapdb_inst_root(db_nm); var sdb_i = new sdbInstance(); sdb_i.dbName = db_nm; sdb_i.dbHost = db_host; sdb_i.dbVer = db_ver[0] + "." + db_ver[1]; sdb_i.ctlUser = sapdb_get_db_user("CONTROL", db_nm, db_host); sdb_i.ctlUserPasswd = sapdb_get_db_user_passwd("CONTROL", db_nm, db_host); var actorObj = new SdbExtActor(); actorObj.setSdbInstance(sdb_i); actorObj.setDbmCmd("DB_CREATE"); actorObj.setExecutable(sapdb_dbmcli_path()); actorObj.setDbRoot(dep_root); var rv = actorObj.sessionExecute(); ASSERT(arguments.callee, rv == "OK", " SDB: ERROR CREATING DATABASE INSTANCE! Check the XCMDOUT.LOG FILE"); var creation_ok = false; var i_size = actorObj.outSize(); for (var i = 0; i < i_size; i++) { var s_line = actorObj.getOutputLine(i); if (/OK/.test(s_line)) { creation_ok = true; } } ASSERT(arguments.callee, creation_ok, "SDB: ERROR WHILE DB INSTANCE CREATION! CHECK THE XCMDOUT.LOG FILE! ");} SDB: ERROR CREATING DATABASE INSTANCE! Check the XCMDOUT.LOG FILE

ERROR 2013-07-12 15:51:12

CJS-00030 Assertion failed: in function sapdb_inst_root(db_nm) { var inst_root = ""; var r_call = sdb_inst_enum(); for (var r_cnt = 0; r_cnt < r_call.length; r_cnt++) { var re = /\s+\t*/; var re_db = new RegExp(db_nm, "i"); var db_enum = r_call[r_cnt].split(re); if (re_db.test(db_enum[1])) { inst_root = db_enum[1]; } } ASSERT(arguments.callee, inst_root != "", "SDB: no installation for Database: '" + db_nm + "' was found!"); return inst_root;}SDB: no installation for Database: 'PLM' was found!

The target system already contains a SAP Solution Manager installation with a MAXDB software 7.7. So I tried to use this software version as well. Strange enough that it mentions a missing file (dbmcli.exe) as this is exactly at this location. Checked twice and gave all access rights to the installation user.

Nevertheless, I tried to install the MAXDB server manually for the new instance which worked and created the files under "F:\sapdb\PLM\" where the files should be.

But then, when retrying the sapinst I gave me the next error that it can not create the database instance. So the manual step did not solve it and I uninstalled the it again.

I think this is all related to the MAXDB version and access rights but I do not know why!!!

I tried also to install the MAXDB 7.6 version but this installation aborted and did not run sucessfully.

Any help would be great, spent already a lot of hours searching for a solution but did not find anything :-(

Regards,

Andreas

System to install / copy:

ECC 5.00, MaxDB 7.7, non-unicode, 64bit

Data export comes from the old system (ECC 5.00, MaxDB 7.5, non-unicode, 32bit.