Skip to Content
avatar image
Former Member

MessageTransformBean - endSeparator

Hi,

I have a receiver file adapter in which I am using modules to zip the file. I am also using MessageTransformBean to convert the XML to flat file.

The stucture we have for the output is: -

<OUTPUT>

     <LINE>

          some stuff

     </LINE>

     <LINE>

          some more stuff

     </LINE>

</OUTPUT>

The file is being created correctly, and there is a CRLF comand between lines 1 and 2 on the file. The problem is that there is only an LF command at teh end of the file. The receiving system requires a CRLF. Looking at the SAP Help is appears to state that the endSeparator paramater is not used on the last occurance of the column.

Has anyone had this issue in the past and if so what was done to resolve it. I am sure a customer module could be developed for it, but that seems a bit over the top for something so simple.

Thanks

Martin

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jul 09, 2013 at 10:41 AM

    Hi Martin,

    I had a similar issue not long ago. Change your endSeparator from 'nl' suggested by SAP Help, to the following sequence (including quotes):

    '0x0D''0x0A'

    Regards,

    Greg

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Ryan Crosby

      Hi Ryan,

      Its fixed now.I had '0x0D''0x0A' specified as the endSeparator for the OUTPUT recordset also.

      I did come across this module, but the SAP help said to set the parameter name to "convert".

      Thanks for your help.

      Martin

  • Jul 09, 2013 at 10:40 AM

    Hi Martin,

    You can try populating the number of segment 1 more than the requirment with the blank values like below:

    <OUTPUT>

         <LINE>

              some stuff

         </LINE>

         <LINE>

              some more stuff

         </LINE>

         <LINE></LINE>

    </OUTPUT>

    Hope this will create the CRLF in your last line.

    /AB

    Add comment
    10|10000 characters needed characters exceeded