Skip to Content
author's profile photo
Former Member

SAP NW - SSL problem

Hello,

we have enabled SSL in SAP NW patch level 12.

When opening any Detail Navigation folder node we receive warning - The page contains both secure and nonsecure items. Do you want to to display the nonsecure items?

After confirmation everythink works fine. Error is displayed for all users only once after logging in when opening detail navigation folder node. However, it is disturbing and confusing.

We experience this with clean installation, it is not a result of our development effort.

When we monitor HTTP traffic to SAP NW, there is no http request - all requests are using https protocol.

Do you have any ideas?

Thank you.

Regards,

Peter Imrich

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Sep 13, 2005 at 11:25 AM

    Hello Peter,

    there must be some http requests. I've tested it right now in our Portal. As soon I acess a page with an IView filled from our CRM Server which is not yet SSL enabled I got also this message. For all IViews rendered by the Portal I don't get the message.

    Regards

    Gregor

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Gregor Wolf

      Hi,

      we haven't started OSS process to date.

      What platform are you using? What browser?

      In our case, Windows SAP NW/Firefox runs fine. Problem occurs just for Windows SAP NW/IE.

      Peter

  • author's profile photo
    Former Member
    Oct 03, 2005 at 12:08 PM

    Hi,

    We have the exact same problem on SP13. We have tried sniffing with Ethereal but cannot find any HTTP traffic between client and server. It seems to be related to javascript "onclick" events, since this warning shows up on all Javascript functionality like treenodes, iView options etc.

    Anyone?

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Oct 03, 2005 at 12:10 PM

    Some additional info. Check note: 872859. This seems to be a known bug which will be fixed in SP14 to be released in the end of October...........

    Add comment
    10|10000 characters needed characters exceeded