Skip to Content

iFlow (mapping) modified in Eclipse can not be brought back to SAP HCI Spaces in Design stage

Doing adjustments to standard pre-packaged integration content for ERP - C4C (integration package named "SAP Hybris Cloud for Customer Integration with SAP ERP" which has been brought to Customer Workspace beforehand) I used SAP HCI spaces (e.g. Web-based tool). But at some point, I stuck in a situation when I could not do the required mapping in HCI spaces because I needed to use two source fields from IDOC to populate one field in C4C structure based on some mapping logic. I didn't find a way to do that in HCI spaces (to bring second source field into the mapping), so I decided to grab Eclipse IDE and do the adjustment there. The adjustment has been done and deployed successfully. Due to project requirements, we're tracking changes using versions of iFlows we're adapting.

What I realised next is that after modification done in Eclipse I cannot edit appropriate version of the iFlow in Design stage in HCI spaces any longer. I can see that the correct version of iFlow is deployed correctly.

I can see it in Monitor stage in "Manage Integration Content" tile with the latest version originated from Eclipse deployment. I'm able even to jump into this iFlow into the correct (currently deployed) version from "Manage Integration Content" selecting appropriate started iFlow and then using the link "View Integration Flow" in Artifact Details section. But only into "view" mode. It's not possible to edit the iFlow from there. In Design stage there is still previous version of the iFlow available.

Summing up: how to bring the modified in Eclipse iFlow's version back into Design stage?

PS: I also tried to add the jar-file with the iFlow to the same integration package within Customer Workspace (using ADD button and in Upload mode). But it says that such iFlow already exists. Obvious, but why not to allow to add a new version of the existed iFlow using this function?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 11, 2017 at 05:09 AM

    Hello Andrei,

    First thing is by deploying the new version of Integration Project in Eclipse willnot directly get updated in Integration Package of WEB UI( Whatver changes you do it in Eclipse for a integration package needs to be excplicitly updated in WEB UI ).If you want to save your integration package updated version in WEB UI I guess you can give a try like below

    1) Log into WEB UI and navigate to Integration Package where you want to update new integration flow version and follow 1,2 and 3 Steps mentioned in below screen.

    2) Right click on your integration project in eclipse and export it as zip.Then create ZIP from the exported archive having only META-INF and src folders and follow the below step [ note once select your ZIP file automatically Comment section will be appeared ]

    Click on ok and you have updated version of your IFLow available in IFLow.

    You can click on Version [ In above screenshot 1.0.0 ] it will give you both the versions of your IFlow details with last change dates ( if you want to revert back to old IFlow just hover your cursor on old version there you will get a timer kind of icon which will do the needful)

    Regards,

    Sriprasad Shivaram Bhat

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sriprasad,

      Thank you for your complete and detailed answer. It worked for me very well.

      Just to finalize: to make the archive file ready to be imported into HCI space we can deselect bin folder during Export procedure in Eclipse and switch to "Create only selected directories" option. That allows to avoid manual manipulation with the zip file.

      Thanks again and appreciate your help!

  • Jan 11, 2017 at 11:06 AM

    But still. If an iFlow can be easily deployed into HCI from Eclipse, why don't we still have any "one-click" option to transfer iFlow content from Eclipse into HCI customer workspace directly?

    Add comment
    10|10000 characters needed characters exceeded