Skip to Content
author's profile photo Former Member
Former Member

Unable to load GSS-API DLL named "sncgss32.dll"

Hi All,

I am trying to configure SNC without SSO using the below link:

http://help.sap.com/saphelp_nw70ehp1/helpdata/en/b9/0dfa4a0457487bb0e59d304eb1a79a/content.htm

However I am getting the following error:

Unable to load GSS-API DLL named "sncgss32.dll"

I have configured the following parameters

snc/accept_insecure_gui=1
snc/accept_insecure_rfc=1

And downloaded the SNC Client Encryption software from
Installations and Upgrades -> Browse our Download Catalog -> SAP Cryptographic Software

This was installed on my system(Windows 7) successfully.

The SAP GUI version being used is 7.3

I also edited the system entry properties.

Please let me know if something is amiss.

Thanks.

Best Regards,

Anita

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jun 27, 2013 at 09:30 PM

    Hello Anita,

    from http://help.sap.com/saphelp_nw70ehp1/helpdata/en/b4/a040e5f0fe4ceeb7a4d6144f4d0f28/content.htm?frameset=/en/76/ea37bd31794c1da6f1ae9ba5a9df5d/frameset.htm

    "Check that the environment variable SNC_LIB of the client host system is set to <Install_Path_SAP_GUI>\FrontEnd\SapGui\Encryption\secgss.dll"

    Hope this helps

    Rolf-Martin

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Anita,

      the wording of the error message indicates, that it tries to use credentials to authenticate.

      However, at the beginning you mentioned, that you try to configure SNC without SSO.

      Could you please double check, if in the SAP Logon entry you are using to connect, the option to use SNC without SSO is chosen?

      Please refer also to the notes listed unter "More information" on the help.sap.com page you are referencing.

      Best regards

      Rolf-Martin

  • author's profile photo Former Member
    Former Member
    Posted on Jun 30, 2015 at 09:34 AM

    Hello

    I have the environment variable SNC_LIB = gsskrb5.dll

    The file gsskrb5.dll is on C:\Windows\System32 because the sapgui version I use is 32 bits. My windows is 64 bits and my sapqui is 7.40.3.

    I have no issues.

    David

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 22, 2015 at 09:22 AM

    Hello,

    you can try to modify the SNC LIB variable.

    Wrong SNC Libary Configured - Security and Identity Management - SCN Wiki

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.