Skip to Content

Re: java installation component

Hi,

I am having a small query. It is quite ridiculous for most of you guys about this one. But its a doubt for me.

Why do most of the sap products go for installation of j2sdk 1.4.2_x, here x means the patch level.

Here my question, would the other versions of j2sdk like 1.5,1.6 also support the SAP products or they wont be useful in installation procedure.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jun 24, 2013 at 02:08 PM

    I have had success using sap jvm as an alternative to j2sdk 1.4.2.

    Here is an example of sapjvm 4.1:  Support Packages and Patches - J" SAP JVM 4.1" SAP JVM 4.1

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 24, 2013 at 02:27 PM

    Hi

    In the old days, SAP only supported 1.4 Java, but from now on SAP JVM is the only supported Java for new installations.

    Regards,

    Graham

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 25, 2013 at 06:17 AM

    For new SAP Solutions/ Products / Installations higher JVM versions are supported/required now.

    Upto/for SAP Netweaver 7.0  => JVM Version 4 (1.4)

    Netweaver 7.3 Onwards => JVM Version 6 (1.6)

    For Netweaver CE 7.1 (However, I am not sure about this) => JVM Version 5 (1.5) but I have seen a SAP system based on Netweaver Platform using JVM 5.

    Regards,

    Akshay.

    Add comment
    10|10000 characters needed characters exceeded