Skip to Content
author's profile photo Former Member
Former Member

Indexing external CM-Links

Hi everybody,

I have the following problem:

In a new Installation of SAP EP/KMC/TREX (6.0 SPS13) I create a number of external links in a CM-Repository.

I then create an index for the folder in which these links are located. The index runs and tells me everything is fine (Document Status OK, TREX shows no problems, Size of HTML-Documents seem to be ok).

When I now search this index using the standard search in the SAP EP the links are found but it tells a message like:

"No document excerpt available!"

And I can not search for any content in the HTML-Documents behind the link.

This worked bevor in in installation with SPS 12!

Has this changed in SPS 13?

I now the crawler parameter "Follow Link" it is not set, but from a previous question I know it should be only relevant for Web Repositories.

Now the documentation says it is for "hierarchical structures". Do I need to set this now?

Documentation:

http://help.sap.com/saphelp_nw04/helpdata/en/46/5d5040b48a6913e10000000a1550b0/content.htm

Similare there is now a setting "Include Links" in the result filter. Is this helpfull here?

Documentation:

http://help.sap.com/saphelp_nw04/helpdata/en/c0/6f5040b48a6913e10000000a1550b0/content.htm

I am asking because I do not have direct access to the system and can not try by my self and hope you can tell me where to focus my reasearch.

Thanks a lot for your help!

Best regards

Mirko

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 11, 2005 at 08:40 AM

    Hello,

    the problem will be fixed with NW04 SPS14 Patch 1 which is planned to be shipped end of october.

    If you want to index the content of external links you have to add the additional property indexContentOfExternalLink and set it on true, when you create a new index.

    Regards,

    Achim

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 13, 2005 at 12:56 PM

    Hi Mirko,

    have you applied Patch 3 to SPS13?

    This should return you to expected behavior.

    Regards,

    Karsten

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Karsten,

      sorry for the delay. I was in holiday:

      We opened an OSS because Patch 3 did no solve our problem. Possibly SAP will provide a special update due to this problem. But we have not finished the OSS process yet.

      Best regards,

      Mirko

  • author's profile photo Former Member
    Former Member
    Posted on Oct 11, 2005 at 05:35 AM

    Hello,

    the problem is that in our current version the content of the external links is not indexed, only the external link itself. We had to change this that way, because this was the behaviour of older versions and some customers did not want to have a different behaviour.

    Because other customers now also need the feature to index the content of the target of external links, we will make this configurable in the very near future.

    If you put the message on my name, I can give you feedback, when this is available.

    Regards,

    Achim

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.