Skip to Content

JRE 7.25 incompatible with PI Tools

Hi.

After deploying SP07 patches for messaging, af, esr, guilib and tools components in a PI 7.31 double-stack landscape, I verified some system functions.

Java asked to be updated to version 7u25.

When I tried to run Enterprise Services Builder and Integration Builder from the tools directory en error showed up with the following message: LAZY_CLASSLOADING_FAILED  CHECK_LOG.

I think new JRE version 7u25 is incompatible with ESB and IB, but it may be also that tools delivered in SP07 have some issue.

After downgrading Java to JRE 7u21, ESB and IB executed correctly.

Feel free to post feedback if anyone of you have more information about this.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Jul 12, 2013 at 05:13 PM

    I was able to launch both programs after configuring java to show the consol.  In WinXP go to contol pannel->Java->"Advanced" tab->check "Show console" under the Java console section. Win7 is control pannel->programs->java->...etc...

    If you close the console before the program finishes launching, the program will not open.  However, it appears the program will function normally if you close the console window after the program has completed launching.  You may also keep the console open if you prefer. Going back into Java settings and reconfiguring to "hide console" will break the program again, even after a successful launch with the console enabled.  I have confirmed this to work in both XP and Win7.

    We're running PI 7.3 SP8

    -Peter


    PI730_JRE7P25.PNG (11.3 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • thanks Monika !.  That worked for me (single stack PI7.31) - I have Java 1.7.0_25.   Also see this SAP support note (related to 1911069).  I will try this once my desktop is updated with latest version of JAVA - according to this below it should launch straight from PI tools webpage.  We'll see. 😉

      Supportability of Java 1.7 with PI Integration Builder client tools 

      According to SAP note: 1792095 - Supportability of Java 1.7 with PI Integration Builder client tools 

      The Java Development Kit (JDK) 1.7 is now supported, on client PC's, used to launch the PI Integration Builder tools e.g. the Enterrpise Services Repository (ESR) and Integration Builder Directory.

      • Both the 32-bit version and he 64-bit version are now supported.
      • If you have a 32-bit OS it is recommended to use the 32-bit Java version
      • If you have a 64-bit OS it is recommended to use the 64-bit Java version

      ***There are currently known issues with the Java 1.7.0_21 and 1.7.0_25 versions. It is recommended to avoid using these versions if possible.

  • Jul 01, 2013 at 03:26 PM

    A temporary work-around is to have the java Console running in the foreground.

    To disable java auto updates you have to run the java control panel with Administrator Access.  In Windows 7 go to C:\Program Files (x86)\Java\jre7\bin and right click on javacpl.exe.  Select 'Run as Administrator', go to Update Tab and uncheck the updates check.  Apply the change.

    Hope this helps.

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 19, 2013 at 08:29 AM

    I confirm that i have the same problem on PI 7.31 after upgrading to JRE version 7 update 25.

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 19, 2013 at 11:00 AM

    I can confirm that the Enterprise Service Builder (WebStart Swing Client) ceases to work after updating to JRE 7u25 -- in my case experienced on Mac OS X. An error dialog pops up that's only showing paceholder constants such as LAZY_CLASSLOADING_FAILED, CHECK_LOG or CLOSE_BUTTON.

    I had to delete the JavaAppletPlugin and reinstall JRE 7u21 to get it back to work.

    (We are using PI 7.31.)

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 01, 2013 at 11:21 AM

    I had the same problem, but after confirming the error message and restarting the ESB or IB both programms worked like before. That's on Mac OSX Mountain Lion 10.8.4.

    Add comment
    10|10000 characters needed characters exceeded