Skip to Content

Index not appearing among Advanced Search indexes

Hi,

I have created an index but the index is not appearing among a list of other indexes in the Advanced Search page.

My steps for index creation are as below:

1) Go to System Admin > System Config > Knowledge Management > Index Administration.

Click on the Create button

2)

ID = sponsored_links

Name = Sponsored Links Index

Group = No entry

Crawler = standard (and define a schedule as daily)

Parameter

Service = TREX Search

Items to Index = Documents

I haven't assigned any data source.

(I have also tried entering Name & Value fields as 'searchhidden' and 'true').

Click 'Create Index' button.

3) Next, click on Advanced Search link on the top of the portal.

Click on 'Show Indexes'.

The index I created is not displayed.

Could anyone please let me know what I am doing wrong?

Thanks and regards,

MB

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Sep 08, 2005 at 01:17 PM

    Hi MB,

    this is actually a feature and works as designed.

    Advanced search is a UI for end users.

    And as it does not make sense to show an index for searching that has no content to be searched, indexes only show here, after you have assigned at least one data source.

    Regards,

    Karsten

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi again,

      partly see my previous posts.

      The idea of spponsored links is, that they are always searched, but rendered differently. The default behavior of the search is to use all indices, if not otherwise specified. Please proceed according to sponsored links documentation. And, if you wish, try the behavior with the "searchhidden" property either checked or unchecked. For that you will obviously need to maintain some sponsored links and then there will be XMLs in the sppecified folder.

      Of course, it is you choice to set the "searchhidden" or not. The idea of sponsored links simply makes "searchhidden=true" the only sensible option.

      Regards,

      Karsten

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.