Skip to Content
0
Former Member
Jun 06, 2013 at 05:27 PM

Flat file error handling not working as expected

760 Views

While loading csv file as comma delimited file we are getting the error: "The expected number of columns was <22> while the number of columns actually read was <1> . Check the input files for errors or verify the schema specification for the file format. The number of records processed was <xxxxxxx>" .

I verified that the record in the file was incorrect. And in order to skip the invalid record, I set up the Error Handling > Capture row format errors to Yes.

But still I am facing the same issue.

I have seen the option to use adaptable schema. But that wont solve the issue which I have because I want the invalid record to be skipped.

Please suggest how to proceed.