Skip to Content
1
May 30, 2013 at 10:55 PM

'Reset to original' for previously modified SC, or remove NWDI control

179 Views

Some while back we had modifications to both SAP_ESS and SAP_MSS in our Portal system, and of course we have used NWDI to track and manage those modifications during support pack applications. However, we have since dropped the modifications to MSS, using the SAP-delivered code instead, although we still are keeping some ESS modifications. I would like to be able to drop the status of 'modified' for the SAP_MSS component so that I no longer have to wait for length NWDI imports to get updates into our systems and instead can just let JSPM do its work. In the past I successfully managed to do this for SAPPCUI_GP, but I no longer can seem to figure out how to achieve this end.

Our portal is on 7.01 sps10 (currently moving to sps13), and the ESS component is 603 sp10 (moving to sp12; the backend ERP system is 604 sps10 going to sps13). The MSS component is 600 sp20 (moving to sp21). The NWDI system is also on 7.01 sps13.

Starting with our sandbox portal, I redefined the associated NWDI track so that SAP_MSS was no longer marked as developed SC. I kicked things off in JSPM, using the support package stack option, with the system under NWDI control as a DEV/CONS system. Everything worked fine, except that both SAP_ESS and SAP_MSS were recognized as modified and therefore not deployed by JSPM. JSPM is now at 7.01 sp13 pl0 (though internally it reports itself as sp12 pl0, so there must not have been any change from sp12 to sp13).

I thought I would now be clever and restart JSPM using the single support packages option, as in the past this has allowed me to overwrite a modified SC with the SAP-delivered one. No dice. JSPM still insists MSS is a modified component and will not allow deployment except via NWDI.

Ok, fine. It's a sandbox. I can afford to get rough, though I prefer not to, as the idea here is to figure out what I'm going to do in the DEV, TEST, and PROD systems later. Anyway, following the instructions in Note 1462405 (Remove NWDI Control of SAP AS Java for JSPM / SUM), I removed the runtime system from the track, and then restarted JSPM. This didn't work; JSPM still insists that the system is under NWDI control and won't let me deploy the SC. I restarted the SDM and tried again, with no change (actually, I had to restart the SDM after removing the RTS from the track before JSPM could even logon).

After more searching, I found Note 1147113 (JSPM: This system is not under NWDI control), and followed those instructions. In the Jspm.JSPM.DataModel.xml file, sure enough I found the 'nwdiRole' setting still at 'DEV(2)' and the 'nwdiSystem' setting at 'true', so I edited the file per the Note, changing the values to 'NOT_NWDI(0)' and 'false' respectively. I then tried JSPM again, but it still insists the system is under NWDI control. I restarted the SDM after confirming my edits in the xml file, and tried again. It doesn't work.

Per Note 1632696 and SDN Thread 1646379, I deleted the three 'DataModel' files so that JSPM would re-initialize the model from scratch, but it still thinks it's an NWDI-controlled system, and the newly recreated DataModel file doesn't even have a reference to NWDI control at all. Clearly the 7.01 version of JSPM is not getting this information from these xml files, and it is not getting it from NWDI; it's persisting it somewhere else.

Does anyone have any idea where that somewhere else might be? Or how to get JSPM to 'forget' that it once was an NWDI-controlled system? Or if not that, to simply allow me to "reset to original" on a Software Component (similar to what we can do in SPAU and SPDD)?

Best regards,

Matt