Skip to Content

Send an idoc to a SAP PI 7.31 system

HI experts,

I need some help on the following scenario: SAP ECC idoc --> SAP PO --> flat flile


Partner profile on ECC created and looks good. Idoc has status 03 (Data passed to port OK)

On SAP PO, I defined a sender idoc communication channel (IDoc_AAE) and in the communication channel monitor I see status started and running successfully. Also, resource adapter and RFC connections are good I guess.

In the message monitor and the IDOC adapter monitor, I see nothing at all.

What do I miss here?

Thanks a lot

Dimitri

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    May 24, 2013 at 09:55 AM

    I got the problem solved.

    The message type I use on the SAP PO system was different than the message type being sent to SAP PO.

    Kind regards,

    Dimitri

    Add comment
    10|10000 characters needed characters exceeded

  • May 23, 2013 at 09:37 PM

    You might also see whether your receiver file adapter  has any error during conversion from xml to flat file. Also if receiver adapter has any access problem it might not write the file in the specified directory path in the server.  You might also restart the idoc  and file adapter and see if that helps.

    Add comment
    10|10000 characters needed characters exceeded

  • May 24, 2013 at 03:38 AM

    Hi,

    Did you check the adapter specific identifiers in sender business system/ business service. check the ports and logical system name.

    also try to test it by using WE19 and see the idoc control record..for port etc..

    check the idoc status in idx5.

    Regards

    Bhargava krishna

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Dimitri Sannen

      hi Dimitri,

      can you also check the outbound queues on the ECC side. sm58 as well to confirm that the messages are not stuck in queues?

      And one confirmation to check if the sender agreement is present for the IDOC_AAE channel

      regards,

      Ninu

  • May 24, 2013 at 09:18 AM

    Hi ,

    Try to check whether message is get stuck in SM58.

    Add comment
    10|10000 characters needed characters exceeded