Skip to Content

Running addon compatible with SAP B1 2007, SAP B1 8.8,8.81,8.2 on SAP B1 9.0

Hi All,

We have developed an add-on compatible with SAP B1 2007,8.8,8.82,8.1 and it is running successfully on many client machines. Now some of the client want to upgrade their SAP to 9.0. Will there be any compatibility issue of running our addon in SAP B1 9.0.

Thanks and Regards

Utpal Maity

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on May 20, 2013 at 08:40 AM

    Hi Utpal,

    There may be some compatibility issues while running these add-ons. You may need to recompile your add-ons for 9.0 using DLLs of this version.

    Hope it helps...

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 21, 2013 at 12:28 PM

    Hi Utpal,

    SAP Business One 9.0 supports both 32-bit and 64-bit installations. In some cases you will need to recompile your add-on to match the client. This can be set in the Build Mode of the add-on in Visual Studio.

    Please read the Compatibility Guide for Add-ons in SAP Business One 9.0 for the details of how to configure each add-on.

    Best Regards,

    Daniel Goldstein

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.