Skip to Content
author's profile photo Former Member
Former Member

CR Dump ( DYN_CALL_METH_CLASS_NOT_FOUND) while opening for Approval in MDG-M

Hi MDG Guru's,

I'm using Role - SAP_MDGM_MENU_03 to create a CR and then submit it, Approver receives in his worklist and while trying to open for approval,I'm getting DYN_CALL_METH_CLASS_NOT_FOUND Dump while creating of Material.

Category ABAP Programming Error
Runtime Errors DYN_CALL_METH_CLASS_NOT_FOUND
Except. CX_SY_DYN_CALL_ILLEGAL_CLASS
ABAP Program CL_WDR_CLIENT_COMPONENT=======CP
Application Component BC-WD-ABA-RUN
Date and Time 17.05.2013 03:21:08

Attched the Error details

Best Regards,

Srihari

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on May 17, 2013 at 08:37 AM

    Dear Srihari,

    This might be the issue with the excution of Call method in you CR,Please refer to the below link might be help ful to you.

    http://help.sap.com/abapdocu_70/en/ABAPCALL_METHOD.htm

    regards

    shankar

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Shankar,

      Thanks for the link shankar, sorry to say it does not help.

      UI we are using is standard on (MDG 6.1), could any please give a solution/point to the direct based on the error.

      Best Regards,

      Srihari

  • author's profile photo Former Member
    Former Member
    Posted on May 20, 2013 at 05:29 AM

    Hi,

    The issues here appears that your UI might still be calling the old classes.Theses issues usually occur when you upgrade MDG from old versions, instead of new installation.

    You can check the following links:

    1. MDGIMG - > Master Data Governance-> General Settings-> Process Modeling-> Business Activities-> Link Actions with UI applications and Business Activity.
    2. Open the role 'SAP_MDGM_MENU_03' in SU01 and check the assigned UI under each link.
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Guys,

      This issue is solved with help of Oss message raised with SAP. I'm sharing the solution as it would be helpful, please find the fix suggested -

      There was an inconsistency in the runtime object for WDA component USMD_WF_NAVIGATION.
      After regenerating the runtime object this problem is now solved.

      To resolve the inconsistency 2 steps had to be performed:
      1. Call function module WDY_WB_DELETE_LOAD in the test environment
      of SE37; for parameter P_COMPONENT the name of the affected WDA
      component has to be specified (in the above issue USMD_WF_NAVIGATION)2. activate the WDA
      component in SE80.

      Best Regards,
      Srihari Mandapati

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.