Skip to Content
author's profile photo Former Member
Former Member

SRM PO Response always triggers PO Change due to delivery period

We've been seeing a lot of PO Change messages being sent from our SRM system, which turn our to be caused by the PO Response message we are receiving from the remote Ariba Networks system. As soon as a difference is detected between the received message and the original PO in SRM, the PO Change message is sent.

With the help of SAP support, we have found that the only change is in the Schedule line, specifically in the StartDateTime and EndDateTime fields. And this is where the fun starts.

We are only processing regular PO's with Ariba Networks. These PO's have a delivery date... no time. When we send the PO as an XML message to PI, during the mapping to XML the date from the PO is somehow converted into a date/time/timezone format: 2013-05-15T03:00:00-08:00

This message is received in Ariba Networks and there the supplier has to enter a delivery date. Once again, just a date. If the supplier in this example enters 15-05-2013, matching our delivery date and not changing it, this is then sent to PI. PI in turn has to convert it back to the date/time/timezone format, which it can't since it doesn't have any information on the original PO and the default RFC functions like BBP_PD_PO_GETDETAIL will only return the delivery date.

Leaving the field empty is seen as a change. Making up a time/timezone will almost never match the value in SRM and is therefore seen as a change. The logic in SRM that makes up the time/timezone is not a function that can be called in custom coding. We will never be able to replicate the date/time/timezone in SRM, so every PO Response will be treated as a change. Basically we're screwed... and I can't imagine we're the first client to encounter this problem.

What option am I overlooking here?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on May 20, 2013 at 09:16 AM

    Hello Egbert,

    Please try in PI to take up only the delivery date and not convert to timestamp.

    Hope it helps !!

    Regards,

    Catherine

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Mary,

      Thanks for your reply, unfortunately it did not help.

      We have tried several messages from PI:

      Omitting the DeliveryPeriod results in a technical error, it is mandatory.

      Leaving the DeliveryPeriod empty also results in a technical error.

      Only entering a delivery date, same thing.

      Entering a date combined with a time, but omitting the timezone works!

      We are now testing whether that time is always filled with a default value (so far we've only seen 12:00:00), or that we have to determine it some other way. At least the timezone is out of the way 😊

      Regards,

      Egbert

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.