Skip to Content
avatar image
Former Member

Failed to enroll android device on Afaria

Hi,

I Downloaded and installed Afaria service pack 3. When I try to enroll an android device via SSP, we are not able to enroll the device successfully.

After entering the enrollment code it moves to the "Connect Status" page and gives me error as "failed to connect".

Attached are the screenshots of the logs available on the device.

[REDACTED BY MODERATOR]

Thanks,

Vikas

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • May 17, 2013 at 06:43 AM

    Couple of questions:

    1. Do other devices connect correctly e.g. iOS ?

    2. Have you tested that GCM (Google Cloud Messaging) is working correctly ?

    3. I assume you are using Relay Servers, are there any problems shown in the Relay or RSOE sever logs when you turn them up to max ?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi David,

      Reply for your queries:

      1.Other device also not getting connected. But first i am trying to connect android device.

      2.GCM is working correctly. i.e.It is not giving any GCM related error.

      3.No, i am trying it without Relay server.

      I am not getting whether which configuration settings are missing.Please help me.

      Thanks in advanced.

  • avatar image
    Former Member
    May 21, 2013 at 10:08 AM

    I am using Afaria SP3 and done with configuration setting for afaria server whose snapshot are attached with this discussion. But I dont know where i am getting wrong in configuration settings because of that my android device is not getting connected.Error snapshot i had already uploaded in the start of discussion. And i am not sure whether i am using Relay Server or Not.

    [REDACTED BY MODERATOR]

    Thanks,

    Regards,

    Vikas


    Untitled.png (15.1 kB)
    Untitled1.png (12.3 kB)
    Untitled2.png (39.1 kB)
    Untitled4.png (25.1 kB)
    Untitled5.png (52.9 kB)
    Untitled6.png (49.8 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      What i can see you are not using relay server , try to connect directly with xnet connection remove the

      Xnet://serveripaddress:3007

      Set to change from the screenshot what i had seen:

      1.Device communication: unthick the http connection and below use the default xnet://serverip:3007

      2.Access control server http port 3010

      3.Package server setting: untick https from direct access

      Create new enrollment policy and use the conection xnet://servperip:3007

      Note: If u are testing on public network please open the 3007 port from server for public ip which is natted.