Skip to Content
Former Member
May 14, 2013 at 01:37 PM

Starting Startup Agent sapstartsrv FAIL: Timeout issue


Hello All,

We are facing a strange issue and require an urgent help for the same.

Recently we did a system refresh i.e. restore of one system to another system which we have done multiple times earlier but havnt received any issues like this till now.

The problem description is mentioned as below:

We have done a system refresh (restore of database) from CA5 system to CE5 system.

CA5 is the distributed system (where CI and DB are on different hosts) but CE5 is not in distributed environment (CI and DB is in the same host).

The restore and recover of the database finisihed successfully without any issues and database in CE5 is currently up and running fine without any issues. But now when we try to start SAP we get the below error:

ce5adm> startsap

Checking CE5 database

Database is not available via R3trans


Trying to start CE5 database ...

Log file: /home/ce5adm/startdb.log

CE5 database started

Starting Startup Agent sapstartsrv

FAIL: Timeout

Startup of Instance Service failed

See /home/ce5adm/startsap_DVEBMGS04.log for details.

Following are the steps which we have tried in order to start SAP but no luck / nothing worked.

  1. Stopped SEOS on server and tried starting SAP
  2. Did a 'slibclean' and tried starting SAP
  3. Executed command 'sapcontrol -nr 04 -funtion StartService CE5'
  4. Checked with UNIX for any blocked UNIX socket/port, UNIX said nothing found in system log.
  5. New 'sapstartsrv' was used
  6. Done kernel upgrade but still no luck.

We even tried starting SAP with the below command and found the below error in startsap.trc

ce5adm> startsap r3 DVEBGMS04 forsvu2007

No instance profiles found


gotsvu2007: instance profile /usr/sap/CE5/SYS/profile/CE5_DVEBMGS04_gotsvu2007 not found

No instance profiles found.

Exit code 8

Can anyone please help me with the above issue, as we are not able to find any solution to the above problem while starting SAP only.