Skip to Content

[Status Update] I've had it with these motherf*g snakes (aka lost answers) on my motherf*g plane (aka SCN)!

In 3 days it'll be a month since this bug was reported: https://answers.sap.com/questions/69559/csrfattackdetected-4-attempts-needed-until-an-answ.html

Enough is enough. I'm officially done posting any answers on SCN until this is resolved.

15
Show 119
* Please Login or Register to Comment on or Follow discussions.
avatar image
Jan 03, 2017 at 10:23 PM
7.3k

Could result in a long period of separation...

Are you okay if this gray panel get replaced with a white one - in that case you should post an idea

4 Share

Phase 1: Enter Idea (on a completely separate website)
Phase 2: Drum up supporters for it
Phase 3: Errr, we'll think about it.

6 Share

Jelena!!

Don't leave us!!!
<sob>!

3 Share

Hey, I'm not leaving so easily! I'm just refusing to use broken functionality that wastes my time and effort. I totally reserve the right to continue posting snarky comments.

14 Share

Speaking of bugs: it looks like Notification/activities are in total malfunction today.

2 Share


Still are....

0 Share

I don't care about answers as long as you still post discussions and status updates.

2 Share

Steffi, I'm starting to suspect many SCN members, in fact, feel this way. Certainly some folks are probably happily ABAPing their systems into ZSAP without me pestering them with silly questions like "why?" or "what for?". :)

2 Share

I'm just lurking the "New SCN" and search the archives.

Whatelse we can do?

1 Share

Hey Simone,

Are you still lurking? Someone mentioned your name as a MoM who has come back into the fold. Since I had not seen you around posting, wondered if they were speaking a bit out of turn?

Cheers, Mike (Moderator)

SAP Technology RIG

0 Share

Hi Michael!

i'm not really active indeed.

My last relevant apport was starting a fight between SAP and Google here

i think i do not deserve that title again :)

Due the timing, i wonder if you are not looking last year discussion about that: i've been named MoM last august :)

0 Share

Hi Simone,

No, the comment was made internally here at SAP. I didn't think you had really returned as I used to see your posts (back when I could track in communications), but still see a broad swath of content without you being involved.

I hope that at some point we have something useful enough to entice your return, but it will take some time/effort and a sea change in the approach towards the community from those running it at the moment (I see some signs this may be happening, but nothing concrete yet).

Cheers, Mike

0 Share
Show more comments

Relax Jelena.

I've got a lot of bugs reported (for example this was posted on Oct 26, 2016 or this was posted on Dec 7, 2016), or ideas posted, or spaces requested here, and SAP ignore all of them :(

I know you are a "mentor", and a semi-god comparing with me. Maybe SAP should listen more to mentors and mods than me. But I think they are on vacation, or taking a drink in the beach. (Haahaha lol).

Regards from Argentine

2 Share

Thanks, Osvaldo! As far as bugs go, the priority should be given to something with more severity/impact no matter who reported it. I can work around many things but completely losing the whole answer when you click "Submit" is where I draw a line. And I refuse to backup every post like a trained monkey. No one should need to do this and it should've been fixed last year, it's "basicest" functionality.

10 Share

I draw the line at the point, where I dumb down my privacy settings to get the "basicest" site functionality. I'll be waiting patiently until the end of the month in the hope to get the Activity stream and Notifications back, but after that - I will probably give up trying to help others.
I still use notepad to type answers/comments (3 months after the upgrade), but I don't mind that much, really. Notepad++ is better than the available forum editors, I only need to upload the pictures separately.

3 Share

Just hit this again today. Took me three times to post my answer. I guess every time it tells me Saving Draft it really just so I think it is doing something rather than actually saving anything.

2 Share

I think this vacation statement can't be correct, how else could we get new bugs?

4 Share

There are new bugs, and anybody see it.

Click on "+Actions" here (top's page).
How many "Start a discussion" do you see?

Maybe from SAP will tell me that no one posted that in "Using SAP" as a bug, and that it is not valid to publish that in Coffee Corner.

My answer would be: "And no one in the development department visualizes that?"

0 Share

I see one.

0 Share

I see 2! Bug!

start.png (33.5 kB)
2 Share

I see the same problem in Chrome, whereas IE only shows a single 'Start a discussion'

0 Share
Show more comments

I see double "Start Discussion" in Mozilla....but then also, if I am on the main Community page and click my "avatar"/image in top menu/header boilerplate on the drop down menu, I see the order of ....

  • Edit My Profile
  • Notifications
  • Account Settings
  • Followed Activities

but on the notifications or followed activities page, it has the order...

  • Edit My Profile
  • Account Settings
  • Notifications
  • Followed Activities

Bizzaro world!

3 Share
Show more comments

Hi,

This was resolved, right?

Regards,

Moshe

0 Share

I see diddly squat.

1 Share

Hey, me too, wonder what it does. :-]

image.jpg (8.9 kB)
9 Share
Show more comments

Only those who use the application will see it, detached remote developers just deliver a piece of code based on a functional design specification.

Communication is eventually formalized using the CHARM process. The hyped agility can't even survive the first contact with this product. The administration time eats the time needed for functional and integration test. More discussions happen about the right usage of the admin tool than the focus on a solution to the reported problem. A single line of coding needs 10 pages FDS and several hours administration work while the fix just needs a minute.

Overall more people are involved and have their income, so it is good for the global economy.

5 Share

We must be in a union shop with rules like that. Or perhaps the Twilight Zone. :D

1 Share

Put in a call to Mr. Jackson. Only he can save you now. Though he might be too busy filming a Capital One Visa commercial.

2 Share

First of all, apologies for this issue.

We have addressed this issue to our service provider and root cause has been identified. I will let you know when the fix will be applied.

2 Share

Which of all mentioned issues did you mean?

With the current discussion layout it is really hard to find out ...

1 Share

I referring to the bug that sometimes user receive an error when providing an answer "Unable to execute your request"

1 Share

Thanks, Mirko. What about Notifications/Activities?

9bkyr.png (3.5 kB)
0 Share

Are you browsing using iPad?

0 Share

Are you kidding? :) PC, naturally. By the way, I don't get any update any more in notifications for answers, new threads in followed tags, etc.

1 Share
Show more comments

Hi Eli,

is it not loading at all or slow?

0 Share

Not loading at all. Plus, I don't get any notifications in the 'counter' next to avatar. For example, I don't know if you commented on my comment without looking inside the thread. This was not the case before.

0 Share
Show more comments

Doesn't work again this morning :(

0 Share
Show more comments

"We have addressed this issue to our service provider"

oh, you (=SAP) don't maintain that software yourselfe?

Thats a new piece of info to me... (not sure what to make of that...)

best

Joachim

0 Share

This is my new favorite status update. Who'da thunk motherf*g snakes would surpass goats?!?! Strange days indeed!

3 Share

Ironically I was watching the movie during lunch a few weeks ago...perhaps it coincided with the time

Jürgen logged the bug.

3 Share

Hello Jelena,

I know it's no comfort but we did all we could to escalate it internally. Probably due to the holidays it took a little longer than usual as there are 3rd party dependencies in this matter.

I'm waiting for an update from IT and will schedule an emergency meeting with them to discuss this and other AH bugs that were raised, after which I will update you all.

Btw, is this happening on all browsers?

Sorry,

Moshe

0 Share

I use Chrome. Not an expert but rather doubt this information matters in this case.

0 Share

Hi Jelena,

I just wanted to update that I did meet with IT that day. The status stays the same as Mirko shares bellow that we are waiting for the service provider to resolve this issue.

We will update once we have more news.

Regards,

Moshe

0 Share

Hi Jelena,

A fix for this issue was deployed to production. Can you please confirm this was resolved and you no longer receive the error when trying to submit an answer?

Look forward to your feedback,

Moshe

0 Share

Hello Moshe - I'm following this thread, but I never got any notifications about your last comment. :(

0 Share

Hi Denis,

Thanks for the heads-up. I will ping Sajid Amir.

Regards,

Moshe

0 Share

Denis Please feel free to read how Notifications work in the new Community here:

https://blogs.sap.com/2017/01/16/use-notifications-like-a-boss/

https://blogs.sap.com/2017/02/03/understanding-the-comment-thread-structure-on-sap-community/

While the first blog explains the overall notification service, the second one helps with some specifics on how notifications work for comments. Please feel free to reach out to me if you have questions or comments. Currently, user subscriptions (follows) have nothing to do with the notification service. For instance, as you are following this thread, the updates from this thread can be found in Followed Activities. You can filter the activities there by Questions and Answers to filter out all other activities.

0 Share

Yes, I found it after 3 scrolls in activity (after filtering on Q&A).

1 Share
Show more comments

I love all the "ops, sorry.. you know, vacations..." answers.

Holidays started on 24th november when Jurgen pointed out the issue?

Or isn't it a critical problem?

I feel ashmed when I talk with my boss about the quality of SAP Products and then he tries to give a look at the SCN and see this...

2 Share

Once more, no Notifications and as additional cherry on the cake:

if1ms.png (46.5 kB)
0 Share

Hm, has SAP been inspired by Air Canada's famous motto: "We're Not Happy Until You're Not Happy"?

4 Share

In this discussion I had to I click 6 times! on Show more comments, so that I can somehow read...
Then I see this:


Seriously, displaying a comment in 275px wide box, when your horizontal screen estate is 1900px, is not a good design.
Then reordering the replies (in my mind) in some meaningful chronological order, so that I can somehow understand what I read... because we have also the 'more comments' bug, where you can't post a reply to a comment, so you post your comment somewhere else in the discussion.
It is getting harder to force myself into doing such exercise after working hours.
Can we, please, eliminate or at least limit the usage of nested comments in Coffee Corner?
One can type in a main comment:
@jelena.perfiljeva wrote:
http://answers.sap.com/comments/96336/view.html
---> enter some text here
or

@jelena.perfiljeva wrote:
"Thanks, Osvaldo! As far as bugs go, the priority should be given to something with more severity/impact no matter who reported it. I can work around many things but completely losing the whole answer when you click "Submit" is where I draw a line. And I refuse to backup every post like a trained monkey. No one should need to do this and it should've been fixed last year, it's "basicest" functionality."

---> enter some text here

design.jpg (27.4 kB)
3 Share

Just thought the same thing about the comment width. And playing "hide&seek" with new content. *sigh*

It's a bad sign when "power users" like this group loose their interest in participating, because it feels like someone wants to prevent this by making everything more complicated and confusing. :/

3 Share

I couldn't agree more!

1 Share

... and now I can't post any comments. (Oh wow, this one came through somehow.)

0 Share

ahhh:

An Internal error has occurred and we are sorry for the inconvenience."

.....

0 Share

FWIW, I possibly noticed a variant of that one:

I had just submitted an answer but got neither an error message nor was the answer displayed, even when re-displaying the page.

So I thought of this nice feature discussed here...

When adding another answer (with much less text, y'know, I'm eager to learn when I should use less words...), now suddenly my new answer was merged with the first one into one posting.

(Probably that's another achivement of gamification...)

0 Share

I had that, too, once or twice so far!

0 Share

Hi Jelena,

unfortunately this bug is with us way too long already. This is a general issue in the CSRF detection in the core product, and we are looking with the vendor into how to resolve this for quite some time already. The issue is fixed with the next major upgrade, which isn't available for another two month. In the meantime we try to mitigate this, obviously without success yet. We are at a point where we look to more creative solutions on how to resolve this.

I will personally make sure this gets the highest attention, and will keep you updated on this thread.

Apologies for the inconveniences this has caused till now.

3 Share

I suspect that if the vendor is unable to solve the critical bug in a short time then it will be Jive number 2!

1 Share

Did the vendor not deliver, Oliver?

0 Share

This assumption is correct, Jürgen. Unfortunately, the introduced workaround (we try to fix the issue in the background, but sometimes you get a popup asking you to reload the page after copying your unsaved content) needs to stay for a little longer time. Obviously, the fix seems to be harder than expected for the vendor. We are even not getting an ETA anymore for the next major upgrade. The initial two months which we got in January were obviously far too optimistic...

1 Share

Hi Jelena, hi everybody,

as Oliver already outlined in http://answers.sap.com/comments/117513/view.html we are now at the point to implement a creative solution which should help us to bridge the gap between today and the real bugfix by the vendor. I'm sorry for the issues which you've encountered so far - especially when it comes to data loss!

The first workaround was deployed yesterday afternoon CET. Our internal tests were already quite promising, but of course nothing beats real life.

In case you still encounter issues now, please let me know immediately, either here in this thread or directly via e-mail (sebastian.wolf@sap.com).

Thanks and best regards,

Sebastian (SAP Community Architect)

2 Share

OK, I started answering questions again and so far [knock on wood] have not run into any errors, so I'm cautiously optimistic. Thank you!

2 Share

I ran into a similar issue with losing my question today. I was logged in (to the best of my knowledge), spent about 5 minutes typing up a question and submitted only to get an error screen and the question was not saved.

1 Share

Hi Chris,

as outlined in http://answers.sap.com/comments/131546/view.html this could probably be due to some missing refinements in our workaround. I'm sorry for that.

Do you also remember some circumstances (other browser tabs, long inactivity etc.) when this issue happened?

Thanks and best regards, Sebastian

0 Share

I don't believe there was anything special about the circumstances.

I was using IE (not edge), I'd refreshed the coffee corner page which prompted login about 20 minutes prior, then on that same tab I started the question via the top right profile menu. Didn't think to screenshot the message.

EDIT-- happened twice again today trying to post another question:

sap-community.jpg (33.0 kB)
0 Share

Hi Chris,

Did it happen again, since?

Thank you,

Moshe

0 Share

I've only asked 1 or 2 questions since, but no. It has not occurred again.

0 Share

Happened again after attempt to post answer:

0 Share
Show more comments

Didn't have that for a long time, but just now I got the

"An Internal error has occurred and we are sorry for the inconvenience."

Again :-(

[*copying to clipboard before clicking submit*]

Edit: only once so far! *knockonwood*

1 Share

I've been getting these at random at least for a few days already. Lost one [rather elaborate] answer once. :( At other times it just pops up but after a simple page refresh everything is peachy again.

Also for some reason first thing in the morning I'm now getting this every other day:

Again, just goes away with a refresh. These random hiccups are getting rather annoying...

image.jpg (21.5 kB)
0 Share

There's a subject line I had hoped never to see again... :-/

Sorry to you both. Let me check with IT to see if there is some system issue.

Best regards,

--Jerry

0 Share

any news on that Jerry? I see this message more often recently (last 2 weeks) than the 2 months before

0 Share

My apologies. I thought this was resolved. I may need to take a different route to address. Hope to have an answer soon.

--Jerry

0 Share

15 days later ...

1 Share

...Jerry has written mutiple emails and still hasn't gotten an explanation.

I'll shoot off another message.

0 Share

OK, here is the response I received from my tech contact...and an offer to help.

RESPONSE:

That is a known issue which affects the Google Chrome browser.
SAP ID Service is affected by SSL connection errors when using Google Chrome and SAP SSO certificates.
Chrome occasionally fails to establish a secure connection to accounts.sap.com, leading to an interrupted SSO flow.
This is presumably caused by a miscommunication during the SSL handshake between the client and the load-balancer.
Further investigations and a solution would involve the third parties Google and f5 (load-balancer). Work was paused on the issue to fully concentrate on the general product stability and a data center deployment.
We will revalidate this decision after the stabilization work has been completed.

Impact (Jerry's italics)
Google Chrome Browser version 53+ on Microsoft Windows.
Affects internal users with SSO certificates on connections from outside the SAP network.
There is no impact on customers or S-user certificates.

Work-around
If possible deviate to Internet Explorer, Firefox or Safari. Use of Chrome is still possible but may require a page reload

OFFER TO HELP
As you can see from the ital copy above, there was a belief that was an internal-only problem. For any non-SAP employees experiencing this problem, I can put you in touch with my contact -- if you're willing to help her investigate. If you're interested and willing, please send me a DM. If you can't send me a DM, let me know here and I'll contact you.

4 Share
Show more comments
10 |10000 characters needed characters left characters exceeded